aboutsummaryrefslogtreecommitdiff
path: root/net/xray-core/Makefile
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2021-09-08 03:48:23 +0800
committerTianling Shen <cnsztl@immortalwrt.org>2021-09-08 03:48:23 +0800
commit3f448adabba3c36f13fab9463bd405463df79464 (patch)
treee7899b07d64dac2c3bd8b41a8b658c4e77a2a769 /net/xray-core/Makefile
parentf6300370430da8402fc7fd24b0eafe352ef1e7a3 (diff)
xray-core: Update to 1.4.3
- Updated geodata to latest version - Removed upstreamed patches Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'net/xray-core/Makefile')
-rw-r--r--net/xray-core/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/net/xray-core/Makefile b/net/xray-core/Makefile
index 91b7198a1..734ef1023 100644
--- a/net/xray-core/Makefile
+++ b/net/xray-core/Makefile
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=xray-core
-PKG_VERSION:=1.4.2
+PKG_VERSION:=1.4.3
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/XTLS/Xray-core/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=565255d8c67b254f403d498b9152fa7bc097d649c50cb318d278c2be644e92cc
+PKG_HASH:=222c03855aa22cd47a648c63b8fa82d37b36983b5c99dc0e2f3c61a79edbb850
PKG_MAINTAINER:=Tianling Shen <cnsztl@immortalwrt.org>
PKG_LICENSE:=MPL-2.0
@@ -78,24 +78,24 @@ define Package/xray-core/conffiles
/etc/config/xray
endef
-GEOIP_VER:=202106030115
+GEOIP_VER:=202109060310
GEOIP_FILE:=geoip.dat.$(GEOIP_VER)
define Download/geoip
URL:=https://github.com/v2fly/geoip/releases/download/$(GEOIP_VER)/
URL_FILE:=geoip.dat
FILE:=$(GEOIP_FILE)
- HASH:=acf231d7c6461d088ae479fe0c1cb143b5ee3cf7048a897c5a9b7807ab7005df
+ HASH:=ed94122961f358abede9f1954722039d5a0300b614c77cc27d92618c08b97bb8
endef
-GEOSITE_VER:=20210531212831
+GEOSITE_VER:=20210906031055
GEOSITE_FILE:=dlc.dat.$(GEOSITE_VER)
define Download/geosite
URL:=https://github.com/v2fly/domain-list-community/releases/download/$(GEOSITE_VER)/
URL_FILE:=dlc.dat
FILE:=$(GEOSITE_FILE)
- HASH:=332bbe53af49582dbf89bda04ee5e60e474f9293fc368ab55b517fdcd4a78ed2
+ HASH:=7618b876fd5a1066d0b44c1c8ce04608495ae991806890f8b1cbfafe79caf6c1
endef
define Build/Prepare