aboutsummaryrefslogtreecommitdiff
path: root/net/xl2tpd
diff options
context:
space:
mode:
authorAlin Nastac <alin.nastac@gmail.com>2017-12-18 13:31:16 +0100
committerYousong Zhou <yszhou4tech@gmail.com>2017-12-18 21:28:11 +0800
commitc59bea9f43eb11e885c990eb01471f38ce24c071 (patch)
treea6bf88a48eb5dd799505b004dbc36355d7ef34d5 /net/xl2tpd
parent13cbaf85410086d2d8056ed3da09af497cdbdf60 (diff)
xl2tpd: remove demand support from netifd l2tp protocol
This pppd feature does not make sense in L2TP case because the tunnel is already connected when xl2tpd launch pppd process. If a dial-on-demand feature is to be implemented, trigger interface would have to be provided by xl2tpd, not pppd. Signed-off-by: Alin Nastac <alin.nastac@gmail.com>
Diffstat (limited to 'net/xl2tpd')
-rw-r--r--net/xl2tpd/Makefile2
-rw-r--r--net/xl2tpd/files/l2tp.sh10
2 files changed, 3 insertions, 9 deletions
diff --git a/net/xl2tpd/Makefile b/net/xl2tpd/Makefile
index a8d9ef86f..19cd435a6 100644
--- a/net/xl2tpd/Makefile
+++ b/net/xl2tpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=xl2tpd
PKG_VERSION:=1.3.10
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=LICENSE
diff --git a/net/xl2tpd/files/l2tp.sh b/net/xl2tpd/files/l2tp.sh
index 38c80256b..c565d6baa 100644
--- a/net/xl2tpd/files/l2tp.sh
+++ b/net/xl2tpd/files/l2tp.sh
@@ -14,7 +14,6 @@ proto_l2tp_init_config() {
proto_config_add_string "keepalive"
proto_config_add_string "pppd_options"
proto_config_add_boolean "ipv6"
- proto_config_add_int "demand"
proto_config_add_int "mtu"
proto_config_add_int "checkup_interval"
proto_config_add_string "server"
@@ -58,14 +57,9 @@ proto_l2tp_setup() {
done
fi
- local ipv6 demand keepalive username password pppd_options mtu
- json_get_vars ipv6 demand keepalive username password pppd_options mtu
+ local ipv6 keepalive username password pppd_options mtu
+ json_get_vars ipv6 keepalive username password pppd_options mtu
[ "$ipv6" = 1 ] || ipv6=""
- if [ "${demand:-0}" -gt 0 ]; then
- demand="precompiled-active-filter /etc/ppp/filter demand idle $demand"
- else
- demand="persist"
- fi
local interval="${keepalive##*[, ]}"
[ "$interval" != "$keepalive" ] || interval=5