aboutsummaryrefslogtreecommitdiff
path: root/net/xl2tpd
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2014-07-19 12:13:40 +0200
committerSteven Barth <steven@midlink.org>2014-07-19 12:13:40 +0200
commit981f2da45747df72c5ae2c45f265fe8f29af3d52 (patch)
tree4c3f0a713f2c9661812aeace69a65108adcd8907 /net/xl2tpd
parent4cb5f9629337bb749f183726648067b686d66ace (diff)
xl2tpd: rename netifd protocol handler to l2tpv2 to avoid clashes with l2tpv3
Signed-off-by: Steven Barth <steven@midlink.org>
Diffstat (limited to 'net/xl2tpd')
-rw-r--r--net/xl2tpd/Makefile2
-rw-r--r--net/xl2tpd/files/l2tpv2.sh (renamed from net/xl2tpd/files/l2tp.sh)8
2 files changed, 5 insertions, 5 deletions
diff --git a/net/xl2tpd/Makefile b/net/xl2tpd/Makefile
index 7d1f932f3..4e108ab80 100644
--- a/net/xl2tpd/Makefile
+++ b/net/xl2tpd/Makefile
@@ -65,7 +65,7 @@ define Package/xl2tpd/install
$(INSTALL_DATA) ./files/options.xl2tpd $(1)/etc/ppp/
$(INSTALL_DIR) $(1)/lib/netifd/proto
- $(INSTALL_BIN) ./files/l2tp.sh $(1)/lib/netifd/proto
+ $(INSTALL_BIN) ./files/l2tpv2.sh $(1)/lib/netifd/proto
endef
$(eval $(call BuildPackage,xl2tpd))
diff --git a/net/xl2tpd/files/l2tp.sh b/net/xl2tpd/files/l2tpv2.sh
index 867234dbe..6466cf0be 100644
--- a/net/xl2tpd/files/l2tp.sh
+++ b/net/xl2tpd/files/l2tpv2.sh
@@ -8,7 +8,7 @@
init_proto "$@"
}
-proto_l2tp_init_config() {
+proto_l2tpv2_init_config() {
proto_config_add_string "username"
proto_config_add_string "password"
proto_config_add_string "keepalive"
@@ -20,7 +20,7 @@ proto_l2tp_init_config() {
no_device=1
}
-proto_l2tp_setup() {
+proto_l2tpv2_setup() {
local config="$1"
local iface="$2"
local optfile="/tmp/l2tp/options.${config}"
@@ -77,7 +77,7 @@ proto_l2tp_setup() {
xl2tpd-control connect l2tp-${config}
}
-proto_l2tp_teardown() {
+proto_l2tpv2_teardown() {
local interface="$1"
local optfile="/tmp/l2tp/options.${interface}"
@@ -103,5 +103,5 @@ proto_l2tp_teardown() {
}
[ -n "$INCLUDE_ONLY" ] || {
- add_protocol l2tp
+ add_protocol l2tpv2
}