aboutsummaryrefslogtreecommitdiff
path: root/net/wifidog
diff options
context:
space:
mode:
authorMichael Haas <haas@computerlinguist.org>2015-10-25 09:56:55 +0100
committerMichael Haas <haas@computerlinguist.org>2015-10-25 09:56:55 +0100
commite86e8d9d3582f1c548c0827f8abae2bb5df655d8 (patch)
tree8b3e6d66a50e21ace381c259bb1721dfc292681b /net/wifidog
parent5e3254a380c6e4f4ef225071339d16b3d649f3a4 (diff)
wifidog: Bump to 1.3.0
* Updates wifidog to latest upstream release. * Removes patches/100-musl-compat.patch as that's included in 1.3.0 Signed-off-by: Michael Haas <haas@computerlinguist.org>
Diffstat (limited to 'net/wifidog')
-rw-r--r--net/wifidog/Makefile6
-rw-r--r--net/wifidog/patches/100-musl-compat.patch47
2 files changed, 3 insertions, 50 deletions
diff --git a/net/wifidog/Makefile b/net/wifidog/Makefile
index ddc2bb1fa..591f29107 100644
--- a/net/wifidog/Makefile
+++ b/net/wifidog/Makefile
@@ -8,8 +8,8 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=wifidog
-PKG_VERSION:=1.2.1
-PKG_RELEASE=2
+PKG_VERSION:=1.3.0
+PKG_RELEASE=1
PKG_LICENSE:=GPL-2.0
@@ -22,7 +22,7 @@ PKG_LICENSE_FILES:=COPYING
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://github.com/wifidog/wifidog-gateway.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=1.2.1
+PKG_SOURCE_VERSION:=1.3.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_FIXUP:=autoreconf
diff --git a/net/wifidog/patches/100-musl-compat.patch b/net/wifidog/patches/100-musl-compat.patch
deleted file mode 100644
index 599c1fefd..000000000
--- a/net/wifidog/patches/100-musl-compat.patch
+++ /dev/null
@@ -1,47 +0,0 @@
---- a/libhttpd/protocol.c
-+++ b/libhttpd/protocol.c
-@@ -28,6 +28,7 @@
-
- #if defined(_WIN32)
- #else
-+#include <fcntl.h>
- #include <unistd.h>
- #include <sys/file.h>
- #endif
---- a/src/firewall.c
-+++ b/src/firewall.c
-@@ -35,7 +35,6 @@
- #include <pthread.h>
- #include <sys/wait.h>
- #include <sys/types.h>
--#include <sys/unistd.h>
-
- #include <string.h>
-
---- a/src/client_list.c
-+++ b/src/client_list.c
-@@ -31,9 +31,9 @@
- #include <syslog.h>
- #include <errno.h>
- #include <pthread.h>
-+#include <unistd.h>
- #include <sys/wait.h>
- #include <sys/types.h>
--#include <sys/unistd.h>
-
- #include <string.h>
-
---- a/src/util.c
-+++ b/src/util.c
-@@ -33,10 +33,10 @@
- #include <syslog.h>
- #include <errno.h>
- #include <pthread.h>
-+#include <unistd.h>
- #include <sys/wait.h>
- #include <sys/types.h>
- #include <sys/time.h>
--#include <sys/unistd.h>
- #include <netinet/in.h>
- #include <sys/ioctl.h>
- #include <arpa/inet.h>