aboutsummaryrefslogtreecommitdiff
path: root/net/wifidog
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-09-21 10:53:48 +0200
committerPetr Štetiar <ynezz@true.cz>2019-11-18 06:28:57 +0100
commit8383c19b908c17dce8b5572c171e7937f4310748 (patch)
tree709de43e0aa0f7bfdfb5b8f308df58c2b5182b56 /net/wifidog
parentdf4811c6c33e81320d8980305ff63e7f850b1145 (diff)
treewide: fix service status command in procd compatible services
Fix breaking change introduced in the main tree with a commit 7519a36774ca ("base-files,procd: add generic service status") where the old service `status` callback function doesn't work anymore and needs to be renamed to `status_service`. This name was chosen for consistency with start and stop function callbacks, which are using `start_service` and `stop_service` naming schemes. While at it, fix whitespace issues in the status_service as well. Ref: http://lists.infradead.org/pipermail/openwrt-devel/2019-September/019035.html Reported-by: Dirk Brenken <dev@brenken.org> Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'net/wifidog')
-rw-r--r--net/wifidog/Makefile2
-rw-r--r--net/wifidog/files/wifidog.init2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/wifidog/Makefile b/net/wifidog/Makefile
index 03e78a38f..47367e474 100644
--- a/net/wifidog/Makefile
+++ b/net/wifidog/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=wifidog
PKG_VERSION:=1.3.0
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/wifidog/wifidog-gateway
diff --git a/net/wifidog/files/wifidog.init b/net/wifidog/files/wifidog.init
index 6ebf64fbc..3078a001a 100644
--- a/net/wifidog/files/wifidog.init
+++ b/net/wifidog/files/wifidog.init
@@ -17,6 +17,6 @@ start_service() {
procd_close_instance
}
-status() {
+status_service() {
/usr/bin/wdctl status
}