aboutsummaryrefslogtreecommitdiff
path: root/net/wifidog
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-06-17 19:38:55 +0200
committerJo-Philipp Wich <jow@openwrt.org>2015-06-17 19:41:42 +0200
commit2b5856ae7224d6640056ba91f5ec2475d47b46a8 (patch)
treea6b25933217b13bd2da451a49dc7d27a60d5cd30 /net/wifidog
parent4116e327afee80aaea33a16358f5f7c0da687bec (diff)
wifidog: fix musl compatibility
- Fix missing `fcntl.h` in `protocol.c` - Replace nonstandard `sys/unistd.h` includes with `unistd.h` ones Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'net/wifidog')
-rw-r--r--net/wifidog/Makefile2
-rw-r--r--net/wifidog/patches/100-musl-compat.patch47
2 files changed, 48 insertions, 1 deletions
diff --git a/net/wifidog/Makefile b/net/wifidog/Makefile
index ade7606c3..ddc2bb1fa 100644
--- a/net/wifidog/Makefile
+++ b/net/wifidog/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=wifidog
PKG_VERSION:=1.2.1
-PKG_RELEASE=1
+PKG_RELEASE=2
PKG_LICENSE:=GPL-2.0
diff --git a/net/wifidog/patches/100-musl-compat.patch b/net/wifidog/patches/100-musl-compat.patch
new file mode 100644
index 000000000..599c1fefd
--- /dev/null
+++ b/net/wifidog/patches/100-musl-compat.patch
@@ -0,0 +1,47 @@
+--- a/libhttpd/protocol.c
++++ b/libhttpd/protocol.c
+@@ -28,6 +28,7 @@
+
+ #if defined(_WIN32)
+ #else
++#include <fcntl.h>
+ #include <unistd.h>
+ #include <sys/file.h>
+ #endif
+--- a/src/firewall.c
++++ b/src/firewall.c
+@@ -35,7 +35,6 @@
+ #include <pthread.h>
+ #include <sys/wait.h>
+ #include <sys/types.h>
+-#include <sys/unistd.h>
+
+ #include <string.h>
+
+--- a/src/client_list.c
++++ b/src/client_list.c
+@@ -31,9 +31,9 @@
+ #include <syslog.h>
+ #include <errno.h>
+ #include <pthread.h>
++#include <unistd.h>
+ #include <sys/wait.h>
+ #include <sys/types.h>
+-#include <sys/unistd.h>
+
+ #include <string.h>
+
+--- a/src/util.c
++++ b/src/util.c
+@@ -33,10 +33,10 @@
+ #include <syslog.h>
+ #include <errno.h>
+ #include <pthread.h>
++#include <unistd.h>
+ #include <sys/wait.h>
+ #include <sys/types.h>
+ #include <sys/time.h>
+-#include <sys/unistd.h>
+ #include <netinet/in.h>
+ #include <sys/ioctl.h>
+ #include <arpa/inet.h>