aboutsummaryrefslogtreecommitdiff
path: root/net/wget/patches
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2022-11-29 20:03:26 +0200
committerHannu Nyman <hannu.nyman@iki.fi>2022-11-29 20:22:40 +0200
commita694130993d9d9eed8689ecdc1d6044dca3dc40e (patch)
treeb666f910e86b4ffa07661dddf23e496cd8edc472 /net/wget/patches
parentd115eec84f22ca87e83d284c88e525f19e5fa4b4 (diff)
wget: update to 1.21.3
Update wget to 1.21.3 * Remove patch 100-fix-hsts-time.patch as upstream has issued its own version on the fixes * Add a hack (and fixup autoreconf) to fix an upstream bug that forces the nettle library into nossl even if NTLM is disabled. Upstream bug filed: https://savannah.gnu.org/bugs/?63431 * Remove old maintainer who has not been active Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'net/wget/patches')
-rw-r--r--net/wget/patches/001-fix-nettle-ntml.patch18
-rw-r--r--net/wget/patches/100-fix-hsts-time.patch54
2 files changed, 18 insertions, 54 deletions
diff --git a/net/wget/patches/001-fix-nettle-ntml.patch b/net/wget/patches/001-fix-nettle-ntml.patch
new file mode 100644
index 000000000..1cddf4070
--- /dev/null
+++ b/net/wget/patches/001-fix-nettle-ntml.patch
@@ -0,0 +1,18 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -630,6 +630,7 @@ then
+ AC_DEFINE([ENABLE_NTLM], 1, [Define if you want the NTLM authorization support compiled in.])
+ fi
+ else
++ if test x"$ENABLE_NTLM" != xno; then
+ PKG_CHECK_MODULES([NETTLE], nettle, [
+ HAVE_NETTLE=yes
+ LIBS="$NETTLE_LIBS $LIBS"
+@@ -651,6 +652,7 @@ else
+ ENABLE_NTLM=yes
+ AC_DEFINE([ENABLE_NTLM], 1, [Define if you want the NTLM authorization support compiled in.])
+ fi
++ fi
+ fi
+
+ dnl **********************************************************************
diff --git a/net/wget/patches/100-fix-hsts-time.patch b/net/wget/patches/100-fix-hsts-time.patch
deleted file mode 100644
index 964d2957b..000000000
--- a/net/wget/patches/100-fix-hsts-time.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From: Huangbin Zhan <zhanhb88@gmail.com>
-Date: Tue, 9 Nov 2021 23:05:55 +0800
-Subject: [PATCH] hsts.c: fix timestamp reading and writing.
-
-Always get zero time on big endian 32bit OS with 64bit time_t such as mips_24kc_musl.
----
- src/hsts.c | 16 ++++++++--------
- 1 file changed, 8 insertions(+), 8 deletions(-)
-
---- a/src/hsts.c
-+++ b/src/hsts.c
-@@ -280,7 +280,7 @@ hsts_read_database (hsts_store_t store,
-
- char host[256];
- int port;
-- time_t created, max_age;
-+ uintmax_t created, max_age;
- int include_subdomains;
-
- func = (merge_with_existing_entries ? hsts_store_merge : hsts_new_entry);
-@@ -293,15 +293,15 @@ hsts_read_database (hsts_store_t store,
- if (*p == '#')
- continue;
-
-- items_read = sscanf (p, "%255s %d %d %lu %lu",
-+ items_read = sscanf (p, "%255s %d %d %"SCNuMAX" %"SCNuMAX,
- host,
- &port,
- &include_subdomains,
-- (unsigned long *) &created,
-- (unsigned long *) &max_age);
-+ &created,
-+ &max_age);
-
- if (items_read == 5)
-- func (store, host, port, created, max_age, !!include_subdomains);
-+ func (store, host, port, (time_t) created, (time_t) max_age, !!include_subdomains);
- }
-
- xfree (line);
-@@ -326,10 +326,10 @@ hsts_store_dump (hsts_store_t store, FIL
- struct hsts_kh *kh = (struct hsts_kh *) it.key;
- struct hsts_kh_info *khi = (struct hsts_kh_info *) it.value;
-
-- if (fprintf (fp, "%s\t%d\t%d\t%lu\t%lu\n",
-+ if (fprintf (fp, "%s\t%d\t%d\t%"PRIuMAX"\t%"PRIuMAX"\n",
- kh->host, kh->explicit_port, khi->include_subdomains,
-- (unsigned long) khi->created,
-- (unsigned long) khi->max_age) < 0)
-+ (uintmax_t) khi->created,
-+ (uintmax_t) khi->max_age) < 0)
- {
- logprintf (LOG_ALWAYS, "Could not write the HSTS database correctly.\n");
- break;