aboutsummaryrefslogtreecommitdiff
path: root/net/wget/Makefile
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2020-04-06 10:20:55 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2020-04-14 11:37:04 +0800
commit585e4a38feca24c9650d4e762b44146ecd75d4d0 (patch)
tree6559efe2f1eae23a38ef50688771e81dd78c16c9 /net/wget/Makefile
parent7ad02ef9e0cdbec8dece24d75e95f229bb4fae02 (diff)
wget: make the ssl variant provides wget-ssl
This is to address the need for specifying dependency on a wget implementation with ssl support. Now we have a game of names for opkg 1. uclient-fetch: minimal version by openwrt project 2. wget-nossl: gnu wget w/o ssl support 3. wget-ssl: for the moment since this commit, gnu wget w/ ssl support 4. wget: uclient-fetch, wget-nossl, or wget-ssl 5. gnu-wget: wget-nossl or wget-ssl By the time we provide some dummy package like uclient-fetch-ssl and make it also provide wget-ssl, I guess by then we will also need gnu-wget-ssl... Ref: https://github.com/openwrt/packages/issues/11534 Ref: https://github.com/openwrt/packages/pull/9941 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'net/wget/Makefile')
-rw-r--r--net/wget/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/net/wget/Makefile b/net/wget/Makefile
index 9664a37d5..ffad46109 100644
--- a/net/wget/Makefile
+++ b/net/wget/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=wget
PKG_VERSION:=1.20.3
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
@@ -46,6 +46,7 @@ $(call Package/wget/Default)
DEPENDS+= +libopenssl +librt
TITLE+= (with SSL support)
VARIANT:=ssl
+ PROVIDES+=wget-ssl
ALTERNATIVES:=300:/usr/bin/wget:/usr/bin/wget-ssl
endef