aboutsummaryrefslogtreecommitdiff
path: root/net/wg-installer
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-01-10 23:56:36 +0100
committerNick Hainke <vincent@systemli.org>2022-01-11 00:27:43 +0100
commit5e8301d7dc154b27b03dc2c24c111e41bb897293 (patch)
tree72a375780f535c8ec6bea03266d047f8ebc8097d /net/wg-installer
parent2978bc1977096184b3f4e18601000db835c15e70 (diff)
wg-installer: fix using symlinks for conf files
It is useful to symlink babeld and olsrd to /tmp/ if we frequently write to those config files. Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'net/wg-installer')
-rw-r--r--net/wg-installer/Makefile4
-rw-r--r--net/wg-installer/wg-server/hotplug.d/99-mesh-babeld4
-rw-r--r--net/wg-installer/wg-server/hotplug.d/99-mesh-olsrd4
3 files changed, 6 insertions, 6 deletions
diff --git a/net/wg-installer/Makefile b/net/wg-installer/Makefile
index 00701701a..55e654d65 100644
--- a/net/wg-installer/Makefile
+++ b/net/wg-installer/Makefile
@@ -54,7 +54,7 @@ endef
define Package/wg-installer-server-hotplug-babeld
$(call Package/wg-installer-server)
- DEPENDS:=wg-installer-server
+ DEPENDS:=wg-installer-server +coreutils-dirname +coreutils-realpath
endef
define Package/wg-installer-server-hotplug-babeld/install
@@ -64,7 +64,7 @@ endef
define Package/wg-installer-server-hotplug-olsrd
$(call Package/wg-installer-server)
- DEPENDS:=wg-installer-server
+ DEPENDS:=wg-installer-server +coreutils-dirname +coreutils-realpath
endef
define Package/wg-installer-server-hotplug-olsrd/install
diff --git a/net/wg-installer/wg-server/hotplug.d/99-mesh-babeld b/net/wg-installer/wg-server/hotplug.d/99-mesh-babeld
index 068b199a1..4da7caa91 100644
--- a/net/wg-installer/wg-server/hotplug.d/99-mesh-babeld
+++ b/net/wg-installer/wg-server/hotplug.d/99-mesh-babeld
@@ -14,7 +14,7 @@ fi
if [ "${ACTION}" == "add" ]; then
uci add babeld interface
uci set babeld.@interface[-1].ifname="${INTERFACE}"
- uci commit
+ uci -c "$(dirname $(realpath /etc/config/babeld))" commit babeld
/etc/init.d/babeld reload
fi
@@ -26,6 +26,6 @@ if [ "${ACTION}" == "remove" ]; then
fi
i=$((i+1));
done
- uci commit
+ uci -c "$(dirname $(realpath /etc/config/babeld))" commit babeld
/etc/init.d/babeld reload
fi
diff --git a/net/wg-installer/wg-server/hotplug.d/99-mesh-olsrd b/net/wg-installer/wg-server/hotplug.d/99-mesh-olsrd
index 648ef6989..1e4be3697 100644
--- a/net/wg-installer/wg-server/hotplug.d/99-mesh-olsrd
+++ b/net/wg-installer/wg-server/hotplug.d/99-mesh-olsrd
@@ -16,7 +16,7 @@ if [ "${ACTION}" == "add" ]; then
uci set olsrd.@Interface[-1].ignore=0
uci set olsrd.@Interface[-1].interface="${INTERFACE}"
uci set olsrd.@Interface[-1].Mode="ether"
- uci commit
+ uci -c "$(dirname $(realpath /etc/config/olsrd))" commit olsrd
/etc/init.d/olsrd reload
fi
@@ -28,6 +28,6 @@ if [ "${ACTION}" == "remove" ]; then
fi
i=$((i+1));
done
- uci commit
+ uci -c "$(dirname $(realpath /etc/config/olsrd))" commit olsrd
/etc/init.d/olsrd reload
fi