aboutsummaryrefslogtreecommitdiff
path: root/net/wg-installer/Makefile
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-01-20 14:10:12 +0100
committerNick Hainke <vincent@systemli.org>2022-01-20 14:44:26 +0100
commit324fa79d7c8a90e899a81bbb3ae0c5a5a602f88e (patch)
tree207b7edcfca14f96399419d53ea9f75df4875bb0 /net/wg-installer/Makefile
parent432a965689f09c6bb86cd24753f79d739b9bcf46 (diff)
wg-installer: create wireguard key if it does not exist
Check if the key exists which is given by option wg_key '/etc/wgserver/wg.key' Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'net/wg-installer/Makefile')
-rw-r--r--net/wg-installer/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net/wg-installer/Makefile b/net/wg-installer/Makefile
index 1d8127105..9718b9c16 100644
--- a/net/wg-installer/Makefile
+++ b/net/wg-installer/Makefile
@@ -22,7 +22,7 @@ define Package/wg-installer-server
$(call Package/wg-installer/Default)
TITLE+= (server)
MENU:=1
- DEPENDS+=+rpcd +uhttpd +uhttpd-mod-ubus
+ DEPENDS+=+rpcd +uhttpd +uhttpd-mod-ubus +coreutils-dirname
endef
define Package/wg-installer-server/install
@@ -57,7 +57,7 @@ endef
define Package/wg-installer-server-hotplug-babeld
$(call Package/wg-installer-server)
- DEPENDS:=wg-installer-server +coreutils-dirname +coreutils-realpath
+ DEPENDS:=wg-installer-server +coreutils-realpath
endef
define Package/wg-installer-server-hotplug-babeld/install
@@ -67,7 +67,7 @@ endef
define Package/wg-installer-server-hotplug-olsrd
$(call Package/wg-installer-server)
- DEPENDS:=wg-installer-server +coreutils-dirname +coreutils-realpath
+ DEPENDS:=wg-installer-server +coreutils-realpath
endef
define Package/wg-installer-server-hotplug-olsrd/install