aboutsummaryrefslogtreecommitdiff
path: root/net/v2ray-geodata
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2024-04-15 15:20:07 +0800
committerTianling Shen <cnsztl@gmail.com>2024-04-19 10:56:03 +0800
commitd7e63d4e24599c66ae9e4c8984398f826108c5c5 (patch)
tree83f9296b9c0dcd824c3b6fa583fd313ff56b035a /net/v2ray-geodata
parentde4ef9d169a182350796afca778742bf68052af4 (diff)
v2ray-geodata: make PKG_RELEASE numeric again
According to the documentation[1] 'PKG_RELEASE' should be a number, so polulate the APK-style 'r' via 'VERSION' instead. 1. https://openwrt.org/docs/guide-developer/packages#buildpackage_variables Fixes: 30796c59485b ("v2ray-geodata: use APK compatible version schema") Reported-by: Sean Khan <datapronix@protonmail.com> Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'net/v2ray-geodata')
-rw-r--r--net/v2ray-geodata/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/net/v2ray-geodata/Makefile b/net/v2ray-geodata/Makefile
index c10eb41cb..7329519f1 100644
--- a/net/v2ray-geodata/Makefile
+++ b/net/v2ray-geodata/Makefile
@@ -5,7 +5,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=v2ray-geodata
-PKG_RELEASE:=r1
+PKG_RELEASE:=1
PKG_LICENSE_FILES:=LICENSE
PKG_MAINTAINER:=Tianling Shen <cnsztl@immortalwrt.org>
@@ -51,7 +51,7 @@ define Package/v2ray-geoip
$(call Package/v2ray-geodata/template)
TITLE:=GeoIP List for V2Ray
PROVIDES:=v2ray-geodata xray-geodata xray-geoip
- VERSION:=$(GEOIP_VER)-$(PKG_RELEASE)
+ VERSION:=$(GEOIP_VER)-r$(PKG_RELEASE)
LICENSE:=CC-BY-SA-4.0
endef
@@ -59,7 +59,7 @@ define Package/v2ray-geosite
$(call Package/v2ray-geodata/template)
TITLE:=Geosite List for V2Ray
PROVIDES:=v2ray-geodata xray-geodata xray-geosite
- VERSION:=$(GEOSITE_VER)-$(PKG_RELEASE)
+ VERSION:=$(GEOSITE_VER)-r$(PKG_RELEASE)
LICENSE:=MIT
endef
@@ -67,7 +67,7 @@ define Package/v2ray-geosite-ir
$(call Package/v2ray-geodata/template)
TITLE:=Iran Geosite List for V2Ray
PROVIDES:=xray-geosite-ir
- VERSION:=$(GEOSITE_IRAN_VER)-$(PKG_RELEASE)
+ VERSION:=$(GEOSITE_IRAN_VER)-r$(PKG_RELEASE)
LICENSE:=MIT
endef