aboutsummaryrefslogtreecommitdiff
path: root/net/uanytun
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2017-12-06 22:55:45 +0100
committerAlexander Couzens <lynxis@fe80.eu>2017-12-06 22:56:41 +0100
commit89e40113f6e56f61163cbe7a702f5b8db389e916 (patch)
tree373cd8b5b3537552bc1170e069df64379bd84dab /net/uanytun
parent52124bf283529661ddd39afdbea4283b44ea2b68 (diff)
uanytun: remove build time/host to fix reproducible builds
Build timestamps prevents reproducible builds [0]. [0] https://reproducible-builds.org/docs/timestamps/ Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'net/uanytun')
-rw-r--r--net/uanytun/Makefile2
-rw-r--r--net/uanytun/patches/100-reproducible-builds.patch12
2 files changed, 13 insertions, 1 deletions
diff --git a/net/uanytun/Makefile b/net/uanytun/Makefile
index ddce67cbf..ef7b3914d 100644
--- a/net/uanytun/Makefile
+++ b/net/uanytun/Makefile
@@ -13,7 +13,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=uanytun
PKG_VERSION:=0.3.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.anytun.org/download/
diff --git a/net/uanytun/patches/100-reproducible-builds.patch b/net/uanytun/patches/100-reproducible-builds.patch
new file mode 100644
index 000000000..a5aa864ae
--- /dev/null
+++ b/net/uanytun/patches/100-reproducible-builds.patch
@@ -0,0 +1,12 @@
+Index: uanytun-0.3.5/src/options.c
+===================================================================
+--- uanytun-0.3.5.orig/src/options.c
++++ uanytun-0.3.5/src/options.c
+@@ -481,7 +481,6 @@ void options_print_usage()
+ void options_print_version()
+ {
+ printf("%s\n", VERSION_STRING_0);
+- printf("%s\n", VERSION_STRING_1);
+ }
+
+ void options_print(options_t* opt)