aboutsummaryrefslogtreecommitdiff
path: root/net/tor
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-02-15 03:55:02 -0800
committerRosen Penev <rosenp@gmail.com>2020-02-15 03:55:02 -0800
commitacabb2cf50726ccafc3cb44aab4307440b2035a4 (patch)
tree52a5a243a142486ece6255f97d85fdf6f2cb2160 /net/tor
parent349d26ac6c5d6caa87a017e9bdfcdefbaae04da2 (diff)
tor: fix init scripts
pidfile should not be set. tor handles it. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net/tor')
-rw-r--r--net/tor/Makefile2
-rw-r--r--net/tor/files/tor.init1
2 files changed, 1 insertions, 2 deletions
diff --git a/net/tor/Makefile b/net/tor/Makefile
index d62b12901..f9f980af9 100644
--- a/net/tor/Makefile
+++ b/net/tor/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tor
PKG_VERSION:=0.4.2.6
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://dist.torproject.org/ \
diff --git a/net/tor/files/tor.init b/net/tor/files/tor.init
index 8512b9843..142e2512d 100644
--- a/net/tor/files/tor.init
+++ b/net/tor/files/tor.init
@@ -48,6 +48,5 @@ start_service() {
procd_set_param command /usr/sbin/tor --runasdaemon 0
procd_append_param command -f "$TORRC_GEN"
procd_set_param respawn
- procd_set_param pidfile /var/run/tor.pid
procd_close_instance
}