aboutsummaryrefslogtreecommitdiff
path: root/net/telnet-bsd/Makefile
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2017-06-24 17:36:42 +0200
committerPaul Spooren <mail@aparcar.org>2022-09-01 11:09:52 +0200
commit51d381e5493f5d414316dfb8f6d8464683e9be11 (patch)
tree16438c2a52dd731a45a5639aa80a6ecb911635ac /net/telnet-bsd/Makefile
parent2840abb0c049061618e4e32c5f59c20f7d081c67 (diff)
telnet-bsd: add package
net/telnet-bsd: Add telnet-bsd 1.2 to repo Patch sources: https://gitweb.gentoo.org/repo/gentoo.git/tree/net-misc/telnet-bsd/files https://ftp.uni-erlangen.de/gentoo-portage/net-misc/telnet-bsd/files Template for excluding telnetd: https://github.com/theeternalsw0rd/telnet-macos Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net> [set me as maintainer, add patches suggested by @pkgadd] Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'net/telnet-bsd/Makefile')
-rw-r--r--net/telnet-bsd/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/net/telnet-bsd/Makefile b/net/telnet-bsd/Makefile
new file mode 100644
index 000000000..1655c631e
--- /dev/null
+++ b/net/telnet-bsd/Makefile
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2017 Daniel Engberg <daniel.engberg.lists@pyret.net>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=telnet-bsd
+PKG_VERSION=1.2
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Paul Spooren <mail@aparcar.org>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=COPYING
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://mirror.netcologne.de/gentoo/distfiles/
+PKG_SOURCE_SUBDIR=$(PKG_NAME)-$(PKG_VERSION)
+PKG_HASH:=d6a9d26740ef75565cb1ed8ff11e327d240e6734748b2d1d2e96c126849e4733
+
+PKG_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_CFLAGS+= -Wno-format-security
+
+define Package/telnet-bsd
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=+libncurses
+ TITLE:=telnet-bsd
+ URL:=https://www.openbsd.org/
+endef
+
+define Package/telnet-bsd/description
+ Telnet client ported from OpenBSD
+endef
+
+define Package/telnet-bsd/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/telnet/telnet $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,telnet-bsd))