aboutsummaryrefslogtreecommitdiff
path: root/net/tcpreplay
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2022-02-07 11:13:55 +0200
committerRosen Penev <rosenp@gmail.com>2022-02-08 14:18:51 -0800
commit3ebd7e7e5feab6932dceb0e39d56139f7089091b (patch)
treee99fd281648f56817e775e3a979b78716dedd4f2 /net/tcpreplay
parent6a0a55a5ed1dea0be1f87cc86a64634c434dc729 (diff)
tcpreplay: bump to version 4.4.0
Also need to use musl-fts when building with musl now. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'net/tcpreplay')
-rw-r--r--net/tcpreplay/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/net/tcpreplay/Makefile b/net/tcpreplay/Makefile
index 525c700f6..1aef5c6b2 100644
--- a/net/tcpreplay/Makefile
+++ b/net/tcpreplay/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=tcpreplay
-PKG_VERSION:=4.3.4
-PKG_RELEASE:=1
+PKG_VERSION:=4.4.0
+PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/appneta/tcpreplay/releases/download/v$(PKG_VERSION)
-PKG_HASH:=42c055106e55852c29d94bb6e1b9e001a0723349f2985eb893a47d384c85002b
+PKG_HASH:=28f64bf57e60d9a0b71cdc355e118c00645ab8092f54fd8b38c74571be77c355
PKG_LICENSE:=GPL-3.0
PKG_LICENSE_FILES:=docs/LICENSE
@@ -35,7 +35,7 @@ define Package/tcpreplay/default
CATEGORY:=Network
URL:=http://tcpreplay.appneta.com/
MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
- DEPENDS:=+librt +libpcap +libdnet
+ DEPENDS:=+librt +libpcap +libdnet +USE_MUSL:musl-fts
endef
define Package/tcpbridge
@@ -127,6 +127,10 @@ define Package/tcpreplay-all/description
to support switches, routers, and IP Flow/NetFlow appliances.
endef
+ifneq ($(CONFIG_USE_MUSL),)
+ TARGET_LDFLAGS+= -lfts
+endif
+
CONFIGURE_VARS += \
ac_cv_lib_nl_nl_cache_alloc=no \
ac_cv_lib_nl_genl_3_genl_connect=no \