aboutsummaryrefslogtreecommitdiff
path: root/net/tailscale
diff options
context:
space:
mode:
authorTyler Young <git@yfh.addy.io>2023-08-27 20:58:10 -0400
committerTianling Shen <cnsztl@gmail.com>2023-08-28 21:59:55 +0800
commit40d5ba9378127a852b0b4735b02798be17e2e12c (patch)
tree906e8f7687930e50b4353d133309755ccda8dfc9 /net/tailscale
parent8dc77f326788e8e28359be1208488ef6c22b738b (diff)
tailscale: enable autodect of fw type
Signed-off-by: Tyler Young <git@yfh.addy.io>
Diffstat (limited to 'net/tailscale')
-rw-r--r--net/tailscale/Makefile2
-rw-r--r--net/tailscale/files/tailscale.init3
2 files changed, 4 insertions, 1 deletions
diff --git a/net/tailscale/Makefile b/net/tailscale/Makefile
index 8cd236efb..48152ec90 100644
--- a/net/tailscale/Makefile
+++ b/net/tailscale/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tailscale
PKG_VERSION:=1.48.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/tailscale/tailscale/tar.gz/v$(PKG_VERSION)?
diff --git a/net/tailscale/files/tailscale.init b/net/tailscale/files/tailscale.init
index 6548fa220..7d5f52134 100644
--- a/net/tailscale/files/tailscale.init
+++ b/net/tailscale/files/tailscale.init
@@ -23,6 +23,9 @@ start_service() {
procd_open_instance
procd_set_param command /usr/sbin/tailscaled
+ # starting with v1.48.1 ENV variable is required to enable autodetection of iptables / nftables
+ procd_set_param env TS_DEBUG_FIREWALL_MODE=auto
+
# Set the port to listen on for incoming VPN packets.
# Remote nodes will automatically be informed about the new port number,
# but you might want to configure this in order to set external firewall