aboutsummaryrefslogtreecommitdiff
path: root/net/tailscale
diff options
context:
space:
mode:
authorZephyr Lykos <git@mochaa.ws>2023-05-25 17:54:06 +0800
committerTianling Shen <cnsztl@gmail.com>2023-05-27 13:14:01 +0800
commit3d368ddc35a3e73aadfd9e53784e2ff5c26cacff (patch)
treef6856ace67c4d75552b9875f5e65498b22d2ef4d /net/tailscale
parentf0b30847dac1c708257a44e12b5884841270e7b3 (diff)
tailscale: update to 1.42.0
Signed-off-by: Zephyr Lykos <git@mochaa.ws>
Diffstat (limited to 'net/tailscale')
-rw-r--r--net/tailscale/Makefile4
-rw-r--r--net/tailscale/patches/010-fake_iptables.patch4
2 files changed, 4 insertions, 4 deletions
diff --git a/net/tailscale/Makefile b/net/tailscale/Makefile
index e71978a8e..0199bd150 100644
--- a/net/tailscale/Makefile
+++ b/net/tailscale/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=tailscale
-PKG_VERSION:=1.40.1
+PKG_VERSION:=1.42.0
PKG_RELEASE:=1
PKG_SOURCE:=tailscale-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/tailscale/tailscale/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=9c0a9648c921f695fc501536e69c8b4998d318256c8049de538f72fbe1491c18
+PKG_HASH:=09de9bacda98de8d733cff162572b7eac857d13db783776ba2a2450a44ecc5e9
PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec1@gmail.com>
PKG_LICENSE:=BSD-3-Clause
diff --git a/net/tailscale/patches/010-fake_iptables.patch b/net/tailscale/patches/010-fake_iptables.patch
index 2874f53b0..ca7086ed8 100644
--- a/net/tailscale/patches/010-fake_iptables.patch
+++ b/net/tailscale/patches/010-fake_iptables.patch
@@ -7,8 +7,8 @@
+replace github.com/coreos/go-iptables => ./patched/go-iptables
+
require (
- filippo.io/mkcert v1.4.3
- github.com/Microsoft/go-winio v0.6.0
+ filippo.io/mkcert v1.4.4
+ github.com/Microsoft/go-winio v0.6.1
--- a/patched/go-iptables/iptables/iptables.go
+++ b/patched/go-iptables/iptables/iptables.go
@@ -149,12 +149,39 @@ func New(opts ...option) (*IPTables, err