aboutsummaryrefslogtreecommitdiff
path: root/net/sysrepo/patches
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2020-05-05 21:07:28 +0300
committerLucian Cristian <lucian.cristian@gmail.com>2020-05-07 00:25:57 +0300
commit1953132ceaccbe2020af810ebf2370ccb3cf9f70 (patch)
treeabb7871045f0e35fed72aed90497e4dd3cb5e2cf /net/sysrepo/patches
parent87ba072dce8ea5c320b08d69bef4c0ecf4f1a238 (diff)
sysrepo: update to 1.4.2
Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
Diffstat (limited to 'net/sysrepo/patches')
-rw-r--r--net/sysrepo/patches/002-remove-buildtime-module-install.patch24
-rw-r--r--net/sysrepo/patches/004-disable-sysrepod-autostart.patch23
-rw-r--r--net/sysrepo/patches/005-fix-struct-ucred-define.patch28
3 files changed, 0 insertions, 75 deletions
diff --git a/net/sysrepo/patches/002-remove-buildtime-module-install.patch b/net/sysrepo/patches/002-remove-buildtime-module-install.patch
deleted file mode 100644
index 2a703bbe8..000000000
--- a/net/sysrepo/patches/002-remove-buildtime-module-install.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -335,7 +335,7 @@ install (FILES ${INTERNAL_YANGS} DESTINATION ${INTERNAL_SCHEMA_SEARCH_DIR})
-
- # install NACM YANG module
- if(ENABLE_NACM)
-- INSTALL_YANG("ietf-netconf-acm" "@2018-02-14" "644")
-+# INSTALL_YANG("ietf-netconf-acm" "@2018-02-14" "644")
- endif(ENABLE_NACM)
-
- # generate and install pkg-config file
-@@ -356,9 +356,9 @@ if(WITH_SYSTEMD)
- FILES_MATCHING PATTERN "*.service")
- endif()
-
--INSTALL_YANG("ietf-netconf-notifications" "" "666")
--INSTALL_YANG("nc-notifications" "" "666")
--INSTALL_YANG("notifications" "" "666")
-+#INSTALL_YANG("ietf-netconf-notifications" "" "666")
-+#INSTALL_YANG("nc-notifications" "" "666")
-+#INSTALL_YANG("notifications" "" "666")
-
- # uninstall
- add_custom_target(uninstall "${CMAKE_COMMAND}" -P "${CMAKE_MODULE_PATH}/uninstall.cmake")
diff --git a/net/sysrepo/patches/004-disable-sysrepod-autostart.patch b/net/sysrepo/patches/004-disable-sysrepod-autostart.patch
deleted file mode 100644
index 255b4ad67..000000000
--- a/net/sysrepo/patches/004-disable-sysrepod-autostart.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/src/clientlib/client_library.c
-+++ b/src/clientlib/client_library.c
-@@ -396,13 +396,13 @@ sr_connect(const char *app_name, const sr_conn_options_t opts, sr_conn_ctx_t **c
- if (opts & SR_CONN_DAEMON_REQUIRED) {
- if ((opts & SR_CONN_DAEMON_START) && (0 == getuid())) {
- /* sysrepo daemon start requested and process is running under root privileges */
-- SR_LOG_DBG_MSG("Sysrepo daemon not detected, starting it.");
-- ret = system("sysrepod");
-- if (0 == ret) {
-- SR_LOG_INF_MSG("Sysrepo daemon has been started.");
-- } else {
-- SR_LOG_WRN("Unable to start sysrepo daemon, error code=%d.", ret);
-- }
-+ //SR_LOG_DBG_MSG("Sysrepo daemon not detected, starting it.");
-+ //ret = system("sysrepod");
-+ //if (0 == ret) {
-+ // SR_LOG_INF_MSG("Sysrepo daemon has been started.");
-+ //} else {
-+ // SR_LOG_WRN("Unable to start sysrepo daemon, error code=%d.", ret);
-+ //}
- /* retry to connect again in any case */
- rc = cl_socket_connect(connection, SR_DAEMON_SOCKET);
- CHECK_RC_LOG_GOTO(rc, cleanup, "Unable to connect to sysrepod: %s.", sr_strerror(rc));
diff --git a/net/sysrepo/patches/005-fix-struct-ucred-define.patch b/net/sysrepo/patches/005-fix-struct-ucred-define.patch
deleted file mode 100644
index 4c5966de1..000000000
--- a/net/sysrepo/patches/005-fix-struct-ucred-define.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/src/common/sr_utils.c
-+++ b/src/common/sr_utils.c
-@@ -506,14 +506,24 @@ sr_fd_set_nonblock(int fd)
-
- #if defined(SO_PEERCRED)
-
-+#if defined(__GLIBC__)
- #if !defined(SCM_CREDENTIALS)
--/* struct ucred is ifdefined behind __USE_GNU, but __USE_GNU is not defined */
- struct ucred {
- pid_t pid; /* process ID of the sending process */
- uid_t uid; /* user ID of the sending process */
- gid_t gid; /* group ID of the sending process */
- };
- #endif /* !defined(SCM_CREDENTIALS) */
-+#else
-+#if !defined(_GNU_SOURCE)
-+struct ucred {
-+ pid_t pid; /* process ID of the sending process */
-+ uid_t uid; /* user ID of the sending process */
-+ gid_t gid; /* group ID of the sending process */
-+};
-+/* struct ucred is ifdefined behind __USE_GNU, but __USE_GNU is not defined */
-+#endif /* !defined(__GNU_SOURCE) */
-+#endif /* defined(__GLIBC__) */
-
- int
- sr_get_peer_eid(int fd, uid_t *uid, gid_t *gid)