aboutsummaryrefslogtreecommitdiff
path: root/net/subversion
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2020-01-27 22:42:02 +0100
committerSebastian Kemper <sebastian_ml@gmx.net>2020-01-27 22:57:58 +0100
commit604a02fe6d32dcdc51cbd52bcd51874d91a84b57 (patch)
tree74be4a966efadc470ed98f4454bcc95caadcfd42 /net/subversion
parentde83b54a8d2b92b38ff135fe85008d35982a0c25 (diff)
subversion: fix build failure
Since commit a62c0e5 apu-1-config is no longer being stipped down with regards to being called with "--link-libtool". Example: $ ./staging_dir/target-mips_24kc_musl/usr/bin/apu-1-config --link-libtool -L/home/sk/tmp/openwrt/staging_dir/target-mips_24kc_musl/usr/lib -R/home/sk/tmp/openwrt/staging_dir/target-mips_24kc_musl/usr/lib -laprutil-1 $ Before the mentioned commit the "-R" argument was stripped off. And when the Makefile adds this to TARGET_LDFLAGS this then ends up in the compiler test, as an argument for the compiler, causing build failure: checking whether the C compiler works... no configure: error: in `/builder/shared-workdir/build/sdk/build_dir/target-arm_mpcore+vfp_musl_eabi/subversion-1.13.0': configure: error: C compiler cannot create executables config.log shows what's wrong: configure:3140: x86_64-openwrt-linux-musl-gcc -Os -pipe ... <snip> ... -R/home/sk/tmp/sdk/master-x86-64/staging_dir/target-x86_64_musl/usr/lib -laprutil-1 conftest.c >&5 x86_64-openwrt-linux-musl-gcc: error: unrecognized command line option '-R' This commit does away with these flags, they're not needed anyway. FPIC is also removed, because it's detrimental to the applications [1] and unnecessary as well. Fixes: #11139 [1] https://wiki.gentoo.org/wiki/Project:Hardened/Position_Independent_Code_internals Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'net/subversion')
1 files changed, 1 insertions, 5 deletions
diff --git a/net/subversion/Makefile b/net/subversion/Makefile
index 6987f38c0..29d0d6426 100644
--- a/net/subversion/Makefile
+++ b/net/subversion/Makefile
@@ -6,7 +6,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=subversion
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_VERSION:=1.13.0
PKG_SOURCE_URL:=@APACHE/subversion
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -79,10 +79,6 @@ define Package/subversion-server/conffiles
/etc/config/subversion
endef
-TARGET_CFLAGS += $(FPIC)
-APU_LIBS=$(shell $(STAGING_DIR)/usr/bin/apu-1-config --link-libtool --libs)
-TARGET_LDFLAGS += $(APU_LIBS)
-
CONFIGURE_ARGS += \
--with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
--with-apr-util="$(STAGING_DIR)/usr/bin/apu-1-config" \