aboutsummaryrefslogtreecommitdiff
path: root/net/sslh
diff options
context:
space:
mode:
authorGabor Seljan <sgabe@users.noreply.github.com>2020-05-24 18:57:15 +0200
committerGabor Seljan <sgabe@users.noreply.github.com>2020-05-26 19:59:24 +0200
commitf3aaffdd6f4214c01e97601ed0a1baafaae1d48b (patch)
tree27a3978001531fecbf231b181dac4fd2e9bcf4c9 /net/sslh
parent4950a3779750bbafe568e8271da5e6e781ed3310 (diff)
sslh: add capabilities support
Compile with USELIBCAP=1 to make use of POSIX capabilities. This will save the required capabilities needed for transparent proxying for unprivileged processes. Signed-off-by: Gabor Seljan <sgabe@users.noreply.github.com>
Diffstat (limited to 'net/sslh')
-rw-r--r--net/sslh/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/net/sslh/Makefile b/net/sslh/Makefile
index e141f99da..5df307a91 100644
--- a/net/sslh/Makefile
+++ b/net/sslh/Makefile
@@ -26,7 +26,7 @@ define Package/sslh
CATEGORY:=Network
SUBMENU:=Routing and Redirection
TITLE:=SSL/SSH multiplexer
- DEPENDS:=+libconfig +USE_UCLIBC:libpcre +USE_MUSL:libpcre
+ DEPENDS:=+libconfig +libcap +USE_UCLIBC:libpcre +USE_MUSL:libpcre
URL:=https://rutschle.net/tech/sslh/README.html
endef
@@ -36,6 +36,7 @@ define Package/sslh/conffiles
endef
MAKE_FLAGS += \
+ USELIBCAP=1 \
$(if $(CONFIG_USE_GLIBC),USELIBPCRE=,USELIBPCRE=1)
define Package/sslh/install