aboutsummaryrefslogtreecommitdiff
path: root/net/squid/patches
diff options
context:
space:
mode:
authorMarko Ratkaj <marko.ratkaj@sartura.hr>2017-09-19 17:38:19 +0200
committerMarko Ratkaj <marko.ratkaj@sartura.hr>2017-09-25 10:50:44 +0200
commit44f41ff9b66338fa36ab207612c313303fa0f005 (patch)
treef86776af2253b35efb370f42771906f04267a6cd /net/squid/patches
parent0a59bebe69989e2ae3a74aedd18f16f4a446093a (diff)
squid: bump to 3.5.27
Bump Squid to version 3.5.27 and fix broken menuconfig menu. Signed-off-by: Marko Ratkaj <marko.ratkaj@sartura.hr>
Diffstat (limited to 'net/squid/patches')
-rw-r--r--net/squid/patches/001-cross_compile.patch24
-rw-r--r--net/squid/patches/100-mime.patch30
2 files changed, 20 insertions, 34 deletions
diff --git a/net/squid/patches/001-cross_compile.patch b/net/squid/patches/001-cross_compile.patch
index c7493bbce..be9fdcd25 100644
--- a/net/squid/patches/001-cross_compile.patch
+++ b/net/squid/patches/001-cross_compile.patch
@@ -1,24 +1,40 @@
--- a/src/Makefile.in
+++ b/src/Makefile.in
-@@ -7761,3 +7761,3 @@ cache_cf.o: cf_parser.cci
+@@ -7984,7 +7984,7 @@ cache_cf.o: cf_parser.cci
+
+ # cf_gen builds the configuration files.
cf_gen$(EXEEXT): $(cf_gen_SOURCES) $(cf_gen_DEPENDENCIES) cf_gen_defines.cci
- $(BUILDCXX) $(BUILDCXXFLAGS) -o $@ $(srcdir)/cf_gen.cc -I$(srcdir) -I$(top_builddir)/include/ -I$(top_builddir)/src
+ g++ -o $@ $(srcdir)/cf_gen.cc -I$(srcdir) -I$(top_builddir)/include/ -I$(top_builddir)/src
+ # squid.conf.default is built by cf_gen when making cf_parser.cci
+ squid.conf.default squid.conf.documented: cf_parser.cci
--- a/configure
+++ b/configure
-@@ -20133,3 +20133,3 @@ if test "$cross_compiling" = yes; then :
+@@ -20842,7 +20842,7 @@ else
+ if test "$cross_compiling" = yes; then :
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
-as_fn_error $? "cannot run test program while cross compiling
+_as_fn_error $? "cannot run test program while cross compiling
See \`config.log' for more details" "$LINENO" 5; }
-@@ -28289,3 +28289,3 @@ else
+ else
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+@@ -29142,7 +29142,7 @@ else
+ if test "$cross_compiling" = yes; then :
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
-as_fn_error $? "cannot run test program while cross compiling
+_as_fn_error $? "cannot run test program while cross compiling
See \`config.log' for more details" "$LINENO" 5; }
-@@ -28314,3 +28314,3 @@ else
+ else
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+@@ -29167,7 +29167,7 @@ else
+ if test "$cross_compiling" = yes; then :
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
-as_fn_error $? "cannot run test program while cross compiling
+_as_fn_error $? "cannot run test program while cross compiling
See \`config.log' for more details" "$LINENO" 5; }
+ else
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
diff --git a/net/squid/patches/100-mime.patch b/net/squid/patches/100-mime.patch
deleted file mode 100644
index 1138a413d..000000000
--- a/net/squid/patches/100-mime.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/src/mime.conf.default
-+++ b/src/mime.conf.default
-@@ -1,20 +1,3 @@
--## Copyright (C) 1996-2015 The Squid Software Foundation and contributors
--##
--## Squid software is distributed under GPLv2+ license and includes
--## contributions from numerous individuals and organizations.
--## Please see the COPYING and CONTRIBUTORS files for details.
--##
--#
--# This file associates URL patterns for servers or services
--# that don't automatically include Content-Type (like ftp) with a mime type
--# and a graphical icon.
--#
--# Content-Encodings are taken from section 3.1 of RFC2068 (HTTP/1.1)
--#
--# This file has the format :
--#
--# regexp content-type icon encoding mode actions
--#--------------------------------------------------------------------------------------------------------
- \.gif$ image/gif silk/image.png - image +download
- \.mime$ www/mime silk/page_white_text.png - ascii +download
- ^internal-dirup$ - silk/arrow_up.png - -
-@@ -191,6 +174,4 @@ README text/plain silk/information.pn
- \.xml$ text/xml silk/page_world.png - ascii +download
- \.xsl$ text/xml silk/layout.png - ascii +download
- \.xyz$ chemical/x-xyz silk/chart_line.png - image +download
--#
--# the default
- . text/plain silk/bullet_red.png - image +download +view