aboutsummaryrefslogtreecommitdiff
path: root/net/spawn-fcgi/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2015-03-29 21:31:26 +0200
committerDaniel Golle <daniel@makrotopia.org>2015-03-29 21:32:43 +0200
commit2d227ea937919c9b5f84aceda23844e7477679d0 (patch)
treea0b02a6cf1647c73b42c0cd357e87f1ed99d5f4c /net/spawn-fcgi/Makefile
parent2c19060e0b5127754afb4966547d4365e1dc04fe (diff)
spawn-fcgi: import from oldpackages
also bump version, use new download URL and add myself as maintainer. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'net/spawn-fcgi/Makefile')
-rw-r--r--net/spawn-fcgi/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/net/spawn-fcgi/Makefile b/net/spawn-fcgi/Makefile
new file mode 100644
index 000000000..2e83def7c
--- /dev/null
+++ b/net/spawn-fcgi/Makefile
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=spawn-fcgi
+PKG_VERSION:=1.6.4
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=http://download.lighttpd.net/spawn-fcgi/releases-1.6.x/
+PKG_MD5SUM:=a67c098a50cd625fd12adf61b5dd4c32
+
+PKG_LICENSE:=BSD-3c
+PKG_LICENSE_FILES:=COPYING
+
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/spawn-fcgi
+ SUBMENU:=Web Servers/Proxies
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Tool to spawn fastcgi applications
+ URL:=http://redmine.lighttpd.net/projects/spawn-fcgi
+endef
+
+define Package/spawn-fcgi/description
+ spawn-fcgi is used to spawn fastcgi applications
+endef
+
+define Package/spawn-fcgi/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/spawn-fcgi $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,spawn-fcgi))