aboutsummaryrefslogtreecommitdiff
path: root/net/softethervpn
diff options
context:
space:
mode:
authorFederico Di Marco <fededim@gmail.com>2018-03-04 18:50:46 +0100
committerFederico Di Marco <fededim@gmail.com>2018-03-06 20:54:49 +0100
commitd4d9d74082c99fdbd54aff3148c841739cedfbc5 (patch)
tree96536d309d98fb3fa26ca7de08668c4caec9ebc1 /net/softethervpn
parent7049eb17464ac1efbc4f41bbadcc84a5de658b5f (diff)
sstp-client: updated to 1.0.12
softethervpn: updated to 4.25-9656 Signed-off-by: Federico Di Marco <fededim@gmail.com>
Diffstat (limited to 'net/softethervpn')
-rw-r--r--net/softethervpn/Makefile10
-rw-r--r--net/softethervpn/patches/105-nossl3.patch36
2 files changed, 13 insertions, 33 deletions
diff --git a/net/softethervpn/Makefile b/net/softethervpn/Makefile
index dff6729d8..c896e0929 100644
--- a/net/softethervpn/Makefile
+++ b/net/softethervpn/Makefile
@@ -9,14 +9,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=softethervpn
-PKG_VERSION:=4.22-9634
-PKG_VERREL:=beta
-PKG_VERDATE:=2016.11.27
-PKG_RELEASE:=2
+PKG_VERSION:=4.25-9656
+PKG_VERREL:=rtm
+PKG_VERDATE:=2018.01.15
+PKG_RELEASE:=1
PKG_SOURCE:=softether-src-v$(PKG_VERSION)-$(PKG_VERREL).tar.gz
PKG_SOURCE_URL:=http://www.softether-download.com/files/softether/v$(PKG_VERSION)-$(PKG_VERREL)-$(PKG_VERDATE)-tree/Source_Code/
-PKG_HASH:=a37c6edeb7076189382fe2cbeb7c02806b76c13bb64e40bd6a5334fdf47f76c8
+PKG_HASH:=b946dec3da5833ad2be69125224784b8a8e2a4149297d0c0a907ba0e1c4535f8
PKG_BUILD_DIR:=$(BUILD_DIR)/v$(PKG_VERSION)
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/v$(PKG_VERSION)
diff --git a/net/softethervpn/patches/105-nossl3.patch b/net/softethervpn/patches/105-nossl3.patch
index 00e0feaa4..e60258031 100644
--- a/net/softethervpn/patches/105-nossl3.patch
+++ b/net/softethervpn/patches/105-nossl3.patch
@@ -1,33 +1,13 @@
-Index: v4.22-9634/src/Mayaqua/Network.c
+Index: v4.25-9656/src/Mayaqua/Network.c
===================================================================
---- v4.22-9634.orig/src/Mayaqua/Network.c
-+++ v4.22-9634/src/Mayaqua/Network.c
-@@ -13013,20 +13013,28 @@ bool StartSSLEx(SOCK *sock, X *x, K *pri
- }
- else
+--- v4.25-9656.orig/src/Mayaqua/Network.c
++++ v4.25-9656/src/Mayaqua/Network.c
+@@ -13025,7 +13025,7 @@ bool StartSSLEx(SOCK *sock, X *x, K *pri
{
-+#ifndef SSL_OP_NO_SSLv3
if (client_tls == false)
{
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#ifndef SSL_OP_NO_SSLv3
SSL_CTX_set_ssl_version(ssl_ctx, SSLv3_method());
- }
- else
- {
-+#endif // SSL_OP_NO_SSLv3
- SSL_CTX_set_ssl_version(ssl_ctx, SSLv23_client_method());
-+#ifndef SSL_OP_NO_SSLv3
- }
-+#endif // SSL_OP_NO_SSLv3
- }
- sock->ssl = SSL_new(ssl_ctx);
- SSL_set_fd(sock->ssl, (int)sock->socket);
-
- #ifdef SSL_CTRL_SET_TLSEXT_HOSTNAME
-+#ifndef SSL_OP_NO_SSLv3
- if (sock->ServerMode == false && client_tls)
-+#else
-+ if (sock->ServerMode == false)
-+#endif // SSL_OP_NO_SSLv3
- {
- if (IsEmptyStr(sni_hostname) == false)
- {
+ #else
+ SSL_CTX_set_ssl_version(ssl_ctx, SSLv23_method());