aboutsummaryrefslogtreecommitdiff
path: root/net/socat
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2017-11-13 12:16:54 +0100
committerAlexander Couzens <lynxis@fe80.eu>2017-11-17 13:15:48 +0100
commit379afb45eff703de5b6901a2b68cc1b1ac438bd3 (patch)
tree01139755308afcaca39b2db9bf8c209e4ff7e7f2 /net/socat
parenta2de0d04b4be837f8da171af367e65d3e7b4d7cf (diff)
socat: set BUILD_DATE to SOURCE_DATE_EPOCH
Build timestamp prevents reproducible builds [0]. SOURCE_DATE_EPOCH allows to use a timestamp which depends on deterministic behaviour [1]. Fixes reproducible builds. [0] https://reproducible-builds.org/docs/timestamps/ [1] https://reproducible-builds.org/specs/source-date-epoch/ Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'net/socat')
-rw-r--r--net/socat/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net/socat/Makefile b/net/socat/Makefile
index e27689929..8a28c792f 100644
--- a/net/socat/Makefile
+++ b/net/socat/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=socat
PKG_VERSION:=1.7.3.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.dest-unreach.org/socat/download
@@ -67,7 +67,8 @@ CONFIGURE_VARS += \
sc_cv_termios_ispeed="no" \
sc_cv_sys_crdly_shift=9 \
sc_cv_sys_tabdly_shift=11 \
- sc_cv_sys_csize_shift=4
+ sc_cv_sys_csize_shift=4 \
+ BUILD_DATE=$(SOURCE_DATE_EPOCH)
define Package/socat/install
$(INSTALL_DIR) $(1)/usr/bin