aboutsummaryrefslogtreecommitdiff
path: root/net/socat
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-11-10 17:25:29 -0800
committerRosen Penev <rosenp@gmail.com>2018-11-10 17:26:56 -0800
commit17cfc75b9874e288c265e9c0fe24d480fca45731 (patch)
treee803dde97bf94a1f4c7b81a8b28fb881ffe5b274 /net/socat
parent7e36a24dd3a99ba4085d2f4318bef8b8cf0bb318 (diff)
socat: Fix compile with deprecated APIs disabled
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net/socat')
-rw-r--r--net/socat/Makefile2
-rw-r--r--net/socat/patches/200-openssl-deprecated.patch13
2 files changed, 14 insertions, 1 deletions
diff --git a/net/socat/Makefile b/net/socat/Makefile
index be5760107..00e95f0d1 100644
--- a/net/socat/Makefile
+++ b/net/socat/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=socat
PKG_VERSION:=1.7.3.2
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.dest-unreach.org/socat/download
diff --git a/net/socat/patches/200-openssl-deprecated.patch b/net/socat/patches/200-openssl-deprecated.patch
new file mode 100644
index 000000000..07c9e5b0c
--- /dev/null
+++ b/net/socat/patches/200-openssl-deprecated.patch
@@ -0,0 +1,13 @@
+diff --git a/xio-openssl.c b/xio-openssl.c
+index e931983..84ec100 100644
+--- a/xio-openssl.c
++++ b/xio-openssl.c
+@@ -8,6 +8,8 @@
+ #if WITH_OPENSSL /* make this address configure dependend */
+ #include <openssl/conf.h>
+ #include <openssl/x509v3.h>
++#include <openssl/dh.h>
++#include <openssl/bn.h>
+
+ #include "xioopen.h"
+