aboutsummaryrefslogtreecommitdiff
path: root/net/snort3
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2023-11-16 13:08:33 -0800
committerRosen Penev <rosenp@gmail.com>2023-11-18 20:18:43 -0800
commitc990f18f4c233eabcd4e3981ade615d480aea093 (patch)
tree29226526f799b1e563d18b774b3239481e33dbe2 /net/snort3
parent24b751bcf0842381688f80d3303ca736c479912c (diff)
snort3: fix compilation with gcc13
Missing header. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net/snort3')
-rw-r--r--net/snort3/Makefile2
-rw-r--r--net/snort3/patches/010-gcc13.patch14
2 files changed, 15 insertions, 1 deletions
diff --git a/net/snort3/Makefile b/net/snort3/Makefile
index 2849135b2..5e452d180 100644
--- a/net/snort3/Makefile
+++ b/net/snort3/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=snort3
PKG_VERSION:=3.1.74.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/snort3/snort3/archive/refs/tags/
diff --git a/net/snort3/patches/010-gcc13.patch b/net/snort3/patches/010-gcc13.patch
new file mode 100644
index 000000000..4bfaee1db
--- /dev/null
+++ b/net/snort3/patches/010-gcc13.patch
@@ -0,0 +1,14 @@
+--- a/src/network_inspectors/packet_capture/packet_capture.h
++++ b/src/network_inspectors/packet_capture/packet_capture.h
+@@ -20,9 +20,10 @@
+ #ifndef PACKET_CAPTURE_H
+ #define PACKET_CAPTURE_H
+
++#include <cstdint>
+ #include <string>
+
+-void packet_capture_enable(const std::string&, const int16_t g = -1);
++void packet_capture_enable(const std::string&, const std::int16_t g = -1);
+ void packet_capture_disable();
+
+ #endif