aboutsummaryrefslogtreecommitdiff
path: root/net/snort3
diff options
context:
space:
mode:
authorEric Fahlgren <ericfahlgren@gmail.com>2024-04-09 07:23:46 -0700
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2024-04-27 12:28:14 +0200
commitc8b13adaa00d21da5dda89496bce91510cfb4eb6 (patch)
treec1818ce8466e9b9295e14541b3ac753eac483b21 /net/snort3
parenta314f26e991fe5907820f29a8dfe0a80a48b48ba (diff)
snort3: fix bug with unset variable
- Parameter not set in two places: /usr/bin/snort-mgr: eval: line 125: options: parameter not set Reported-by: @klingon888 Signed-off-by: Eric Fahlgren <ericfahlgren@gmail.com>
Diffstat (limited to 'net/snort3')
-rw-r--r--net/snort3/Makefile2
-rw-r--r--net/snort3/files/snort-mgr4
2 files changed, 3 insertions, 3 deletions
diff --git a/net/snort3/Makefile b/net/snort3/Makefile
index 48ce85b45..a8552428b 100644
--- a/net/snort3/Makefile
+++ b/net/snort3/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=snort3
PKG_VERSION:=3.1.84.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_VERSION:=$(PKG_VERSION)
diff --git a/net/snort3/files/snort-mgr b/net/snort3/files/snort-mgr
index 1fc54ca12..3ea1b3e4d 100644
--- a/net/snort3/files/snort-mgr
+++ b/net/snort3/files/snort-mgr
@@ -54,7 +54,7 @@ nft_rm_table() {
nft_add_table() {
if [ "$(uci -q get snort.snort.method)" = "nfq" ]; then
- local options
+ local options=''
$VERBOSE && options='-e'
print nftables | nft $options -f $STDIN
$VERBOSE && nft list table inet snort
@@ -118,7 +118,7 @@ check() {
fi
if [ "$(uci -q get snort.snort.method)" = "nfq" ]; then
- local options
+ local options=''
local test_nft="${CONF_DIR}/test_conf.nft"
print nftables > "${test_nft}" || die "Errors during generation of nftables config"
$VERBOSE && options='-e'