aboutsummaryrefslogtreecommitdiff
path: root/net/snort3
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2021-01-19 22:06:34 -0300
committerEneas U de Queiroz <cotequeiroz@gmail.com>2021-02-24 20:42:03 -0300
commit92cdc620b6a6e9974b1a0d69a482ae02f1dd4d5d (patch)
tree066f0cae3de7f445f6d11d2bf525ac915ec535a2 /net/snort3
parent48e2b6ebb3ebb688de1c8a069c7b43d9478b3298 (diff)
libdaq3,snort3: install/use libdaq3 in its own dir
If used with default paths, libdaq 2.x and libdaq 3.x will overwrite some of the other version's files. Install them in different places to avoid trouble. Snort is the only package that uses libdaq, so update it at the same time to avoid creating a failing commit. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'net/snort3')
-rw-r--r--net/snort3/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/net/snort3/Makefile b/net/snort3/Makefile
index 149667b81..4530596a8 100644
--- a/net/snort3/Makefile
+++ b/net/snort3/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=snort3
PKG_VERSION:=3.1.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.snort.org/downloads/snortplus/
@@ -45,6 +45,8 @@ endef
CMAKE_OPTIONS += \
-DUSE_TIRPC:BOOL=YES \
-DENABLE_STATIC_DAQ:BOOL=NO \
+ -DDAQ_INCLUDE_DIR=$(STAGING_DIR)/usr/include/daq3 \
+ -DDAQ_LIBRARIES_DIR_HINT:PATH=$(STAGING_DIR)/usr/lib/daq3 \
-DENABLE_COREFILES:BOOL=NO \
-DENABLE_GDB:BOOL=NO \
-DMAKE_DOC:BOOL=NO \
@@ -54,8 +56,8 @@ CMAKE_OPTIONS += \
-DHAVE_LIBUNWIND=OFF \
-DHAVE_LZMA=OFF
-TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/tirpc
-TARGET_LDFLAGS += -ltirpc
+TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/daq3 -I$(STAGING_DIR)/usr/include/tirpc
+TARGET_LDFLAGS += -L$(STAGING_DIR)/usr/lib/daq3 -ltirpc
define Package/snort3/conffiles
/etc/config/snort