aboutsummaryrefslogtreecommitdiff
path: root/net/sing-box/Makefile
diff options
context:
space:
mode:
authorVan Waholtz <brvphoenix@gmail.com>2022-12-12 21:59:43 +0800
committerTianling Shen <cnsztl@gmail.com>2023-02-10 08:45:15 +0800
commitc85a23a81eac541c03ed9af78e282d660ecbeae1 (patch)
treef33a45e82c0b95047cbeadb04bb7c4464c262c48 /net/sing-box/Makefile
parent4947b057cfc8e593c47cac06889707f89aff08cd (diff)
sing-box: add new package
Signed-off-by: Van Waholtz <brvphoenix@gmail.com>
Diffstat (limited to 'net/sing-box/Makefile')
-rw-r--r--net/sing-box/Makefile140
1 files changed, 140 insertions, 0 deletions
diff --git a/net/sing-box/Makefile b/net/sing-box/Makefile
new file mode 100644
index 000000000..921f599cc
--- /dev/null
+++ b/net/sing-box/Makefile
@@ -0,0 +1,140 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=sing-box
+PKG_VERSION:=1.1.5
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/SagerNet/sing-box/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=a1e642362f41bd0e362cd9c8d2f0d29d2eca6a55a948677f6f03cfb81c4f0657
+
+PKG_LICENSE:=GPL-3.0-or-later
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Van Waholtz <brvphoenix@gmail.com>
+
+PKG_BUILD_DEPENDS:=golang/host
+PKG_BUILD_PARALLEL:=1
+PKG_USE_MIPS16:=0
+
+GO_PKG:=github.com/sagernet/sing-box
+GO_PKG_BUILD_PKG:=$(GO_PKG)/cmd/sing-box
+
+include $(INCLUDE_DIR)/package.mk
+include ../../lang/golang/golang-package.mk
+
+define Package/sing-box
+ TITLE:=The universal proxy platform
+ SECTION:=net
+ CATEGORY:=Network
+ URL:=https://sing-box.sagernet.org
+ DEPENDS:=$(GO_ARCH_DEPENDS) +ca-bundle +kmod-tun
+ USERID:=sing-box=5566:sing-box=5566
+endef
+
+define Package/sing-box/description
+ Sing-box is a universal proxy platform which supports hysteria, SOCKS, Shadowsocks,
+ ShadowsocksR, ShadowTLS, Tor, trojan, VLess, VMess, WireGuard and so on.
+endef
+
+define Package/sing-box/config
+ menu "Select build options"
+ depends on PACKAGE_sing-box
+
+ config SINGBOX_WITH_ACME
+ bool "Build with ACME TLS certificate issuer support"
+ default n
+
+ config SINGBOX_WITH_CLASH_API
+ bool "Build with Clash API support"
+ default y
+
+ config SINGBOX_WITH_ECH
+ bool "Build with TLS ECH extension support for TLS outbound"
+ default n
+
+ config SINGBOX_WITH_EMBEDDED_TOR
+ bool "Build with embedded Tor support"
+ default n
+
+ config SINGBOX_WITH_GRPC
+ bool "Build with standard gRPC support"
+ default n
+
+ config SINGBOX_WITH_GVISOR
+ bool "Build with gVisor support"
+ default y
+
+ config SINGBOX_WITH_LWIP
+ bool "Build with LWIP Tun stack support"
+ default n
+
+ config SINGBOX_WITH_QUIC
+ bool "Build with QUIC support"
+ default y
+
+ config SINGBOX_WITH_SHADOWSOCKSR
+ bool "Build with ShadowsocksR support"
+ default n
+
+ config SINGBOX_WITH_UTLS
+ bool "Build with uTLS support for TLS outbound"
+ default y
+
+ config SINGBOX_WITH_V2RAY_API
+ bool "Build with V2Ray API support"
+ default n
+
+ config SINGBOX_WITH_WIREGUARD
+ bool "Build with WireGuard support"
+ default y
+ endmenu
+endef
+
+PKG_CONFIG_DEPENDS:= \
+ CONFIG_SINGBOX_WITH_ACME \
+ CONFIG_SINGBOX_WITH_CLASH_API \
+ CONFIG_SINGBOX_WITH_ECH \
+ CONFIG_SINGBOX_WITH_EMBEDDED_TOR \
+ CONFIG_SINGBOX_WITH_GRPC \
+ CONFIG_SINGBOX_WITH_GVISOR \
+ CONFIG_SINGBOX_WITH_LWIP \
+ CONFIG_SINGBOX_WITH_QUIC \
+ CONFIG_SINGBOX_WITH_SHADOWSOCKSR \
+ CONFIG_SINGBOX_WITH_UTLS \
+ CONFIG_SINGBOX_WITH_V2RAY_API \
+ CONFIG_SINGBOX_WITH_WIREGUARD
+
+GO_PKG_TAGS:=$(subst $(space),$(comma),$(strip \
+ $(if $(CONFIG_SINGBOX_WITH_ACME),with_acme) \
+ $(if $(CONFIG_SINGBOX_WITH_CLASH_API),with_clash_api) \
+ $(if $(CONFIG_SINGBOX_WITH_ECH),with_ech) \
+ $(if $(CONFIG_SINGBOX_WITH_EMBEDDED_TOR),with_embedded_tor) \
+ $(if $(CONFIG_SINGBOX_WITH_GRPC),with_grpc) \
+ $(if $(CONFIG_SINGBOX_WITH_GVISOR),with_gvisor) \
+ $(if $(CONFIG_SINGBOX_WITH_LWIP),with_lwip) \
+ $(if $(CONFIG_SINGBOX_WITH_QUIC),with_quic) \
+ $(if $(CONFIG_SINGBOX_WITH_SHADOWSOCKSR),with_shadowsocksr) \
+ $(if $(CONFIG_SINGBOX_WITH_UTLS),with_utls) \
+ $(if $(CONFIG_SINGBOX_WITH_V2RAY_API),with_v2ray_api) \
+ $(if $(CONFIG_SINGBOX_WITH_WIREGUARD),with_wireguard) \
+))
+
+define Package/sing-box/conffiles
+/etc/config/sing-box
+/etc/sing-box/
+endef
+
+define Package/sing-box/install
+ $(INSTALL_DIR) $(1)/usr/bin/
+ $(INSTALL_BIN) $(GO_PKG_BUILD_BIN_DIR)/sing-box $(1)/usr/bin/sing-box
+
+ $(INSTALL_DIR) $(1)/etc/sing-box
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/release/config/config.json $(1)/etc/sing-box
+
+ $(INSTALL_DIR) $(1)/etc/config/
+ $(INSTALL_CONF) ./files/sing-box.conf $(1)/etc/config/sing-box
+ $(INSTALL_DIR) $(1)/etc/init.d/
+ $(INSTALL_BIN) ./files/sing-box.init $(1)/etc/init.d/sing-box
+endef
+
+$(eval $(call BuildPackage,sing-box))