aboutsummaryrefslogtreecommitdiff
path: root/net/sing-box/Makefile
diff options
context:
space:
mode:
authorAnya Lin <hukk1996@gmail.com>2024-01-06 16:46:27 +0800
committerAnya Lin <hukk1996@gmail.com>2024-01-07 12:02:15 +0800
commit8fe2f6848511c3edd2feb46c04c1f8b6ffd1b99e (patch)
tree16cf350b2902faea28b9927894e0a87e4d68b67c /net/sing-box/Makefile
parent6d47f6635672934d8f1a8643955c332854f15604 (diff)
sing-box: update to 1.8.0
New features for v1.8.0: 1. Migrate cache file from Clash API to independent options 2. Introducing Rule Set 3. Add `sing-box geoip`, `sing-box geosite` and `sing-box rule-set` commands 4. Allow nested logical rules 5. Independent `source_ip_is_private` and `ip_is_private` rules 6. Add context to JSON decode error message 7. Reject internal fake-ip queries 8. Add GSO support for TUN and WireGuard system interface 9. The legacy LWIP stack has been deprecated and removed 10. Add `idle_timeout` for URLTest outbound 11. Added some new uTLS fingerprints ... Release notes: https://github.com/SagerNet/sing-box/releases/tag/v1.8.0 The new version has some breaking changes and may stop working after upgrading if use the original config. Please see the migration manual to migrate the config: https://sing-box.sagernet.org/migration/ Signed-off-by: Anya Lin <hukk1996@gmail.com>
Diffstat (limited to 'net/sing-box/Makefile')
-rw-r--r--net/sing-box/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/net/sing-box/Makefile b/net/sing-box/Makefile
index 32134356f..81c73d36b 100644
--- a/net/sing-box/Makefile
+++ b/net/sing-box/Makefile
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=sing-box
-PKG_VERSION:=1.7.7
+PKG_VERSION:=1.8.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/SagerNet/sing-box/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=ce182cb2181e898b56ca9b6ce0d5adeaece8e761ac62ce8cde69b3c7219b8430
+PKG_HASH:=80ae2a860fc77d961c578999e5fcfe964f969c81d9ccac156b2fef1340eca12f
PKG_LICENSE:=GPL-3.0-or-later
PKG_LICENSE_FILES:=LICENSE
@@ -66,9 +66,6 @@ define Package/sing-box/config
bool "Build with gVisor support"
default y
- config SINGBOX_WITH_LWIP
- bool "Build with LWIP Tun stack support"
-
config SINGBOX_WITH_QUIC
bool "Build with QUIC support"
default y
@@ -98,7 +95,6 @@ PKG_CONFIG_DEPENDS:= \
CONFIG_SINGBOX_WITH_EMBEDDED_TOR \
CONFIG_SINGBOX_WITH_GRPC \
CONFIG_SINGBOX_WITH_GVISOR \
- CONFIG_SINGBOX_WITH_LWIP \
CONFIG_SINGBOX_WITH_QUIC \
CONFIG_SINGBOX_WITH_REALITY_SERVER \
CONFIG_SINGBOX_WITH_UTLS \
@@ -113,7 +109,6 @@ GO_PKG_TAGS:=$(subst $(space),$(comma),$(strip \
$(if $(CONFIG_SINGBOX_WITH_EMBEDDED_TOR),with_embedded_tor) \
$(if $(CONFIG_SINGBOX_WITH_GRPC),with_grpc) \
$(if $(CONFIG_SINGBOX_WITH_GVISOR),with_gvisor) \
- $(if $(CONFIG_SINGBOX_WITH_LWIP),with_lwip) \
$(if $(CONFIG_SINGBOX_WITH_QUIC),with_quic) \
$(if $(CONFIG_SINGBOX_WITH_REALITY_SERVER),with_reality_server) \
$(if $(CONFIG_SINGBOX_WITH_UTLS),with_utls) \