aboutsummaryrefslogtreecommitdiff
path: root/net/shadowsocks-libev
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2017-08-13 12:07:07 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2017-08-13 12:39:01 +0800
commitd4ed4c1f21432b95336047bfc9c8c1577a5b0456 (patch)
tree169fc98dfe19e869f331726897affc3b1f552bab /net/shadowsocks-libev
parent37c9b31d7fb87db8d1a70600c71438967926c883 (diff)
shadowsocks-libev: setting mode with default value tcp_only
This is the default value taken by ss-server and ss-redir. After this change ss_rules section can still use those ss-redir instances who do not have mode explicitly specified. Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'net/shadowsocks-libev')
-rw-r--r--net/shadowsocks-libev/Makefile4
-rw-r--r--net/shadowsocks-libev/files/shadowsocks-libev.init2
2 files changed, 3 insertions, 3 deletions
diff --git a/net/shadowsocks-libev/Makefile b/net/shadowsocks-libev/Makefile
index 903ec65c0..25d5e18ab 100644
--- a/net/shadowsocks-libev/Makefile
+++ b/net/shadowsocks-libev/Makefile
@@ -10,11 +10,11 @@ include $(TOPDIR)/rules.mk
# Checklist when bumping versions
#
# - update cipher list by checking src/crypto.c:crypto_init()
-# - check if ss-rules has been upstreamed
+# - check if default mode has changed from being tcp_only
#
PKG_NAME:=shadowsocks-libev
PKG_VERSION:=3.0.8
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/shadowsocks/shadowsocks-libev/releases/download/v$(PKG_VERSION)
diff --git a/net/shadowsocks-libev/files/shadowsocks-libev.init b/net/shadowsocks-libev/files/shadowsocks-libev.init
index ad4fe9ccb..1f43ffdbe 100644
--- a/net/shadowsocks-libev/files/shadowsocks-libev.init
+++ b/net/shadowsocks-libev/files/shadowsocks-libev.init
@@ -274,7 +274,7 @@ validate_common_options_() {
'ipv6_first:bool:0' \
'reuse_port:bool:0' \
'verbose:bool:0' \
- 'mode:or("tcp_only", "udp_only", "tcp_and_udp")' \
+ 'mode:or("tcp_only", "udp_only", "tcp_and_udp"):tcp_only' \
'mtu:uinteger' \
'timeout:uinteger' \
'user:string'