aboutsummaryrefslogtreecommitdiff
path: root/net/shadowsocks-libev
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2017-07-28 14:44:48 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2017-07-28 15:06:24 +0800
commitb7f69c063370f87a15f4e47cda394f6f90c3bd5e (patch)
tree63d44080dec6b9e9fc7fb65eec2fd042ac36eadc /net/shadowsocks-libev
parent99374712ac554b6e36c073f5fec9e30ae26ab522 (diff)
shadowsocks-libev: fix compiling with stale object files
This will cause various kinds of failures in the buildbot ➜ shadowsocks-libev-3.0.7 git:(master) find . -name '*.o' -o -name '*.lo' ./libbloom/murmur2/libbloom_la-MurmurHash2.o ./libbloom/murmur2/libbloom_la-MurmurHash2.lo ./libbloom/libbloom_la-bloom.lo ./libbloom/libbloom_la-bloom.o ➜ shadowsocks-libev-3.0.7 git:(master) ls -l libbloom/murmur2 total 24 -rw-r--r-- 1 yousong yousong 324 Jun 27 14:17 libbloom_la-MurmurHash2.lo -rw-r--r-- 1 yousong yousong 4168 Jun 27 14:17 libbloom_la-MurmurHash2.o -rw-r--r-- 1 yousong yousong 1344 Feb 17 08:47 MurmurHash2.c -rw-r--r-- 1 yousong yousong 142 Feb 17 08:47 murmurhash2.h -rw-r--r-- 1 yousong yousong 213 Feb 17 08:47 README ➜ shadowsocks-libev-3.0.7 git:(master) file ./libbloom/murmur2/libbloom_la-MurmurHash2.o ./libbloom/murmur2/libbloom_la-MurmurHash2.o: ELF 64-bit LSB relocatable, x86-64, version 1 (SYSV), not stripped ➜ shadowsocks-libev-3.0.7 git:(master) Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'net/shadowsocks-libev')
-rw-r--r--net/shadowsocks-libev/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/net/shadowsocks-libev/Makefile b/net/shadowsocks-libev/Makefile
index d8c2631a5..644355f8f 100644
--- a/net/shadowsocks-libev/Makefile
+++ b/net/shadowsocks-libev/Makefile
@@ -19,7 +19,7 @@ include $(TOPDIR)/rules.mk
#
PKG_NAME:=shadowsocks-libev
PKG_VERSION:=3.0.7
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/shadowsocks/shadowsocks-libev/releases/download/v$(PKG_VERSION)
@@ -107,6 +107,16 @@ uci batch <<-EOF
EOF
endef
+define Build/Prepare
+ $(call Build/Prepare/Default)
+ $(FIND) $(PKG_BUILD_DIR) \
+ -name '*.o' \
+ -o -name '*.lo' \
+ -o -name '.deps' \
+ -o -name '.libs' \
+ | xargs rm -rvf
+endef
+
CONFIGURE_ARGS += \
--disable-documentation \
--disable-silent-rules \