aboutsummaryrefslogtreecommitdiff
path: root/net/shadowsocks-libev
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2018-02-01 14:48:49 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2018-02-02 17:24:45 +0800
commit4d211674cef311ba55872d8099ec368f1430d238 (patch)
tree621b760640b36311c1303bf02697b6859d1fe8b8 /net/shadowsocks-libev
parent25757a96fa804241ea04aaae9006efc9aa24648e (diff)
shadowsocks-libev: bump to version 3.1.3
Notable changes since 3.1.2 afce1b3 eliminate timered delay between handshake and data stream #1572 539bf6e sni in redir removed and no disable_sni option #1876 1d94442..29ff5d3 udprelay fix (no idea what's the problem...) #1883 Now disable_sni=true is the default. Existing uci configs setting it will be a nop Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'net/shadowsocks-libev')
-rw-r--r--net/shadowsocks-libev/Makefile6
-rw-r--r--net/shadowsocks-libev/files/shadowsocks-libev.init10
2 files changed, 5 insertions, 11 deletions
diff --git a/net/shadowsocks-libev/Makefile b/net/shadowsocks-libev/Makefile
index 26dd782a6..9a1c07d7b 100644
--- a/net/shadowsocks-libev/Makefile
+++ b/net/shadowsocks-libev/Makefile
@@ -13,12 +13,12 @@ include $(TOPDIR)/rules.mk
# - check if default mode has changed from being tcp_only
#
PKG_NAME:=shadowsocks-libev
-PKG_VERSION:=3.1.2
-PKG_RELEASE:=2
+PKG_VERSION:=3.1.3
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/shadowsocks/shadowsocks-libev/releases/download/v$(PKG_VERSION)
-PKG_HASH:=3611f09793af923d988ecbd15ad89fb66839e51a0059685d8f88c0131658e4a7
+PKG_HASH:=58fb438d2cfe33cfa6ac8c50e587e2138c50e59a4b943f88d22883bf2e192a96
PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
diff --git a/net/shadowsocks-libev/files/shadowsocks-libev.init b/net/shadowsocks-libev/files/shadowsocks-libev.init
index 7564f348e..555cc1855 100644
--- a/net/shadowsocks-libev/files/shadowsocks-libev.init
+++ b/net/shadowsocks-libev/files/shadowsocks-libev.init
@@ -78,11 +78,7 @@ ss_mkjson_ss_local_conf() {
}
ss_mkjson_ss_redir_conf() {
- ss_mkjson_server_conf || return 1
- [ "$disable_sni" = 0 ] && disable_sni=false || disable_sni=true
- cat <<-EOF
- "disable_sni": $disable_sni,
- EOF
+ ss_mkjson_server_conf
}
ss_mkjson_ss_server_conf() {
@@ -276,9 +272,7 @@ validate_ss_local_section() {
}
validate_ss_redir_section() {
- validate_common_client_options_ ss_redir "$1" \
- "${2}" \
- 'disable_sni:bool:0'
+ validate_common_client_options_ ss_redir "$1" "${2}"
}
validate_ss_rules_section() {