aboutsummaryrefslogtreecommitdiff
path: root/net/seafile-seahub
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-06-30 04:41:15 +0800
committerJeffery To <jeffery.to@gmail.com>2020-06-30 15:43:01 +0800
commite0e2224f8a80dd6b93dd00bd1e4a89e5a649c461 (patch)
treec36edeeb713a87bad4e992fcb212a5eeec139f93 /net/seafile-seahub
parent811ff39de5cc3763e4509f852b28a97e9b571a4d (diff)
python-packages: Disable parallel build when host pip is needed
This adds PKG_BUILD_PARALLEL:=0 to packages that depend on host Python packages (HOST_PYTHON3_PACKAGE_BUILD_DEPENDS), because installing packages with multiple concurrent pip processes can lead to errors or unexpected results[1]. This also: * Move HOST_PYTHON3_PACKAGE_BUILD_DEPENDS definitions to before python3-package.mk is included * Update Python folder readme to include PKG_BUILD_PARALLEL:=0 [1]: https://github.com/pypa/pip/issues/2361 Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'net/seafile-seahub')
-rw-r--r--net/seafile-seahub/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/seafile-seahub/Makefile b/net/seafile-seahub/Makefile
index ab1888bf3..28396aaa6 100644
--- a/net/seafile-seahub/Makefile
+++ b/net/seafile-seahub/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=seafile-seahub
PKG_VERSION:=7.1.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/haiwen/seahub/tar.gz/v$(PKG_VERSION)-server?
@@ -23,7 +23,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/seahub-$(PKG_VERSION)-server
HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:="Django~=1.11"
-PKG_BUILD_PARALLEL:=1
+PKG_BUILD_PARALLEL:=0
PYTHON3_PKG_BUILD:=0
include $(INCLUDE_DIR)/package.mk