aboutsummaryrefslogtreecommitdiff
path: root/net/seafile-seahub
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-17 22:35:31 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-19 01:56:23 +0800
commit81e99fa7ffd5439e8fbba5b34a13f80c0e20ea48 (patch)
treeabd201f24428952dfca48892ae6481ce3e02fe61 /net/seafile-seahub
parent1bc2f4f3c6216ece87f0821d68e4e25f821dc382 (diff)
seafile: Remove Python variants, update Python packaging
This removes Python build variants and adds PYTHON3_PKG_BUILD:=0 (where appropriate) for the Seafile packages. This also updates the way the Python bindings packages are packaged, using automake installation instead of manual install recipes. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'net/seafile-seahub')
-rw-r--r--net/seafile-seahub/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/net/seafile-seahub/Makefile b/net/seafile-seahub/Makefile
index 295c7f9f9..d72a2a3bb 100644
--- a/net/seafile-seahub/Makefile
+++ b/net/seafile-seahub/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=seafile-seahub
PKG_VERSION:=7.1.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/haiwen/seahub/tar.gz/v$(PKG_VERSION)-server?
@@ -24,6 +24,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/seahub-$(PKG_VERSION)-server
HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:="Django~=1.11"
PKG_BUILD_PARALLEL:=1
+PYTHON3_PKG_BUILD:=0
include $(INCLUDE_DIR)/package.mk
include ../../lang/python/python3-package.mk
@@ -57,7 +58,6 @@ define Package/seafile-seahub
+python3-requests-oauthlib \
+python3-seafile-ccnet \
+python3-searpc
- VARIANT:=python3
endef
define Package/seafile-seahub/description
@@ -75,10 +75,9 @@ MAKE_VARS += \
PYTHON="$(HOST_PYTHON3_BIN)" \
DJANGO_ADMIN_PY="$(STAGING_DIR_HOSTPKG)/bin/django-admin"
-define Py3Build/Compile
+define Build/Compile
$(call HostPython3/PipInstall,$(HOST_PYTHON3_PACKAGE_BUILD_DEPENDS))
$(call Build/Compile/Default,locale)
- $(INSTALL_DIR) $(PKG_INSTALL_DIR)/$(PYTHON3_PKG_DIR)
endef
define Py3Package/seafile-seahub/install
@@ -90,6 +89,8 @@ define Py3Package/seafile-seahub/install
mv $(1)/usr/share/seafile/seafile-server/seahub/media/avatars $(1)/usr/share/seafile/seafile-server/seahub/media/avatars_default
endef
+Py3Package/seafile-seahub/filespec:=
+
$(eval $(call Py3Package,seafile-seahub))
$(eval $(call BuildPackage,seafile-seahub))
$(eval $(call BuildPackage,seafile-seahub-src))