aboutsummaryrefslogtreecommitdiff
path: root/net/seafile-seahub
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2019-06-03 13:58:39 +0300
committerAlexandru Ardelean <ardeleanalex@gmail.com>2019-06-18 15:07:41 +0300
commit1c5f5b61d3c8515177c6a81be2806a0afd848fe4 (patch)
tree5c341eeea508c0503e12d0e844701fbb366a14b8 /net/seafile-seahub
parentdf6d4f1f784f17ea21ab459f56fa2eeffcc109bf (diff)
seafile-seahub: move all prefix-ed python packages to var
The change is mostly organizational. More packages will be moved to have python- or python3- prefixes. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'net/seafile-seahub')
-rw-r--r--net/seafile-seahub/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/net/seafile-seahub/Makefile b/net/seafile-seahub/Makefile
index 0666d4944..04b6cb39d 100644
--- a/net/seafile-seahub/Makefile
+++ b/net/seafile-seahub/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=seafile-seahub
PKG_VERSION:=6.3.4
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_LICENSE:=Apache-2.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -22,17 +22,20 @@ PKG_BUILD_DEPENDS:=python-pytz/host
include $(INCLUDE_DIR)/package.mk
include ../../lang/python/python-package.mk
+SEAFILE_PYTHON_DEPENDS:= \
+ simplejson chardet dateutil mysql pytz qrcode requests requests-oauthlib
+
define Package/seafile-seahub
SECTION:=net
CATEGORY:=Network
TITLE:=Seafile server - seahub component
URL:=https://seafile.com/
- DEPENDS:=+python-simplejson +python +pillow +python-chardet +django +django-appconf \
+ DEPENDS:=+python +pillow +django +django-appconf \
+django-compressor +django-constance +django-formtools +django-jsonfield \
+django-picklefield +django-postoffice +django-restframework \
+django-simple-captcha +django-statici18n +django-webpack-loader \
- +flup +gunicorn +openpyxl +python-dateutil +python-mysql \
- +python-qrcode +python-requests +python-requests-oauthlib +python-pytz
+ +flup +gunicorn +openpyxl \
+ $(foreach dep,$(SEAFILE_PYTHON_DEPENDS),+python-$(dep))
endef
define Build/Configure