aboutsummaryrefslogtreecommitdiff
path: root/net/scapy
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2015-09-20 19:10:07 -0400
committerW. Michael Petullo <mike@flyn.org>2015-09-20 19:10:27 -0400
commit51adbf46d46d35d4ca65fc4c8fbf2b58f9b7a194 (patch)
treea22ca1a767fa9084a4dd917561d3a216f31b8130 /net/scapy
parentbe21910b9e4256e741676c721b952dcb910591f3 (diff)
scapy: add new package
Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'net/scapy')
-rw-r--r--net/scapy/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/net/scapy/Makefile b/net/scapy/Makefile
new file mode 100644
index 000000000..e8af27a9e
--- /dev/null
+++ b/net/scapy/Makefile
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=scapy
+PKG_VERSION:=2.2.0
+PKG_RELEASE:=1
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=PKG-INFO
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
+PKG_SOURCE_URL:=https://bitbucket.org/secdev/scapy/downloads/
+PKG_MD5SUM:=d68903c5d877820026dc544caa0b5d3c
+
+PKG_BUILD_DEPENDS:=python python-setuptools
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python-package.mk)
+
+define Package/scapy
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Interactive packet manipulation tool and network scanner
+ MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+ URL:=http://www.secdev.org/projects/scapy/
+ DEPENDS:=+python
+endef
+
+define Package/scapy/description
+ Scapy is a powerful interactive packet manipulation program built on top
+ of the Python interpreter. It can be used to forge or decode packets of
+ a wide number of protocols, send them over the wire, capture them, match
+ requests and replies, and much more.
+endef
+
+define Build/Compile
+ $(call Build/Compile/PyMod,., \
+ install --prefix="/usr" --root="$(PKG_INSTALL_DIR)", \
+ )
+endef
+
+define Package/scapy/install
+ $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(CP) \
+ $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+ $(1)$(PYTHON_PKG_DIR)/
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
+endef
+
+$(eval $(call BuildPackage,scapy))