aboutsummaryrefslogtreecommitdiff
path: root/net/rtorrent/patches
diff options
context:
space:
mode:
authorPeter Wagner <tripolar@gmx.at>2014-06-16 11:41:05 +0200
committerPeter Wagner <tripolar@gmx.at>2014-06-16 11:53:44 +0200
commit4c89b9da1abfee848c0d1d80c761f146a736d7ba (patch)
tree795fddadd02dc6ba6dd60f1362386b1dde8a0410 /net/rtorrent/patches
parentfe62d146fa6cb6a4d8321a1bf502c36a811c8d77 (diff)
rtorrent: import from packages and update to 0.9.4
libtorrent: import from packages and update to 0.13.4 Signed-off-by: Peter Wagner <tripolar@gmx.at>
Diffstat (limited to 'net/rtorrent/patches')
-rw-r--r--net/rtorrent/patches/100-fix-cross_compile.patch30
-rw-r--r--net/rtorrent/patches/120-fix-ncurses.patch11
2 files changed, 41 insertions, 0 deletions
diff --git a/net/rtorrent/patches/100-fix-cross_compile.patch b/net/rtorrent/patches/100-fix-cross_compile.patch
new file mode 100644
index 000000000..203544ec3
--- /dev/null
+++ b/net/rtorrent/patches/100-fix-cross_compile.patch
@@ -0,0 +1,30 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -4,7 +4,6 @@ AC_DEFINE(API_VERSION, 8, api version)
+
+ AM_INIT_AUTOMAKE
+ AC_CONFIG_HEADERS(config.h)
+-AM_PATH_CPPUNIT(1.9.6)
+
+ AC_PROG_CXX
+ AC_PROG_LIBTOOL
+--- a/scripts/common.m4
++++ b/scripts/common.m4
+@@ -223,7 +223,7 @@ dnl Need to fix this so that it uses t
+ AC_DEFUN([TORRENT_CHECK_EXECINFO], [
+ AC_MSG_CHECKING(for execinfo.h)
+
+- AC_RUN_IFELSE([AC_LANG_SOURCE([
++ AC_LINK_IFELSE([AC_LANG_SOURCE([
+ #include <execinfo.h>
+ int main() { backtrace((void**)0, 0); backtrace_symbols((char**)0, 0); return 0;}
+ ])],
+@@ -238,7 +238,7 @@ AC_DEFUN([TORRENT_CHECK_EXECINFO], [
+ AC_DEFUN([TORRENT_CHECK_ALIGNED], [
+ AC_MSG_CHECKING(the byte alignment)
+
+- AC_RUN_IFELSE([AC_LANG_SOURCE([
++ AC_LINK_IFELSE([AC_LANG_SOURCE([
+ #include <inttypes.h>
+ int main() {
+ char buf@<:@8@:>@ = { 0, 0, 0, 0, 1, 0, 0, 0 };
diff --git a/net/rtorrent/patches/120-fix-ncurses.patch b/net/rtorrent/patches/120-fix-ncurses.patch
new file mode 100644
index 000000000..f491de36a
--- /dev/null
+++ b/net/rtorrent/patches/120-fix-ncurses.patch
@@ -0,0 +1,11 @@
+--- a/src/display/canvas.h
++++ b/src/display/canvas.h
+@@ -48,7 +48,7 @@ class Canvas {
+ public:
+ typedef std::vector<Attributes> attributes_list;
+
+- Canvas(int x = 0, int y = 0, int width = 0, int height = 0);
++ Canvas(int x = 0, int y = 0, int width = 1, int height = 1);
+ ~Canvas() { delwin(m_window); }
+
+ void refresh() { wnoutrefresh(m_window); }