aboutsummaryrefslogtreecommitdiff
path: root/net/rtorrent/Makefile
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2015-11-06 14:02:55 +0200
committerHannu Nyman <hannu.nyman@iki.fi>2015-11-14 10:34:09 +0200
commitb28a6201cf8028f68a354ea127cc1e519bec17bf (patch)
treeb1ec5c8872faa10c1d694711a8f7f79a00a34b4f /net/rtorrent/Makefile
parent8276f382a9ba0806a3ed713e375a9244cac184fd (diff)
rtorrent: update to 0.9.6, disable ipv6
Update rtorrent to 0.9.6. Update patches. Disable ipv6 in rtorrent, as ipv6 is disabled also in libtorrent. Libtorrent compilation has been broken since #1181 got merged and ipv6 got enabled. Users have seen issues like #1316 and #1804 IPv6 support in libtorrent & rtorrent master is not complete. Instead there is a separate ipv6 branch, which still needs some cleanup before mainstream use. See discussion at https://github.com/rakshasa/rtorrent/issues/59#issuecomment-56651538 So, it makes no sense to use ipv6 with the master branch. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'net/rtorrent/Makefile')
-rw-r--r--net/rtorrent/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/net/rtorrent/Makefile b/net/rtorrent/Makefile
index bba6ddee0..596854eba 100644
--- a/net/rtorrent/Makefile
+++ b/net/rtorrent/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007-2013 OpenWrt.org
+# Copyright (C) 2007-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rtorrent
-PKG_VERSION:=0.9.4-git-1
+PKG_VERSION:=0.9.6-git-1
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/rakshasa/rtorrent.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=7343e33a6a0d279179b304a380bf011f1c8be64a
+PKG_SOURCE_VERSION:=62cb5a4605c0664bc522e0e0da9c72f09cf643a9
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_LICENSE:=GPL-2.0
@@ -73,7 +73,7 @@ CONFIGURE_ARGS+= \
--enable-shared \
--disable-static \
--disable-debug \
- $(call autoconf_bool,CONFIG_IPV6,ipv6)
+ --disable-ipv6
ifeq ($(BUILD_VARIANT),rpc)
CONFIGURE_ARGS += \