aboutsummaryrefslogtreecommitdiff
path: root/net/rsync
diff options
context:
space:
mode:
authorMaxim Storchak <m.storchak@gmail.com>2024-04-14 15:27:28 +0300
committerTianling Shen <cnsztl@gmail.com>2024-04-19 21:51:40 +0800
commit8951378aece0cd33e97d975c2232e66d040582c2 (patch)
tree5313f13b95f7f0bb2fbb870c6f6989794ef3b37d /net/rsync
parenta7172aec504c38693fffe705cd3c661098a496fa (diff)
rsync: support xxhash and lz4
Signed-off-by: Maxim Storchak <m.storchak@gmail.com>
Diffstat (limited to 'net/rsync')
-rw-r--r--net/rsync/Config.in10
-rw-r--r--net/rsync/Makefile10
2 files changed, 15 insertions, 5 deletions
diff --git a/net/rsync/Config.in b/net/rsync/Config.in
index f5e3b67b1..30e86261f 100644
--- a/net/rsync/Config.in
+++ b/net/rsync/Config.in
@@ -17,4 +17,14 @@ if PACKAGE_rsync
prompt "Enable zstd stream compression"
default n
+ config RSYNC_lz4
+ bool
+ prompt "Enable lz4, extremely fast compression"
+ default n
+
+ config RSYNC_xxhash
+ bool
+ prompt "Enable xxhash, extremely fast hash"
+ default n
+
endif
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index e943ac841..723eaa348 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=rsync
PKG_VERSION:=3.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://download.samba.org/pub/$(PKG_NAME)/src
@@ -30,8 +30,8 @@ define Package/rsync
SECTION:=net
CATEGORY:=Network
SUBMENU:=File Transfer
- TITLE:=Fast remote file copy program (like rcp)
- DEPENDS:=+libpopt +zlib +RSYNC_xattr:libattr +RSYNC_acl:libacl +RSYNC_zstd:libzstd $(ICONV_DEPENDS)
+ TITLE:=an open source utility that provides fast incremental file transfer
+ DEPENDS:=+libpopt +zlib +RSYNC_xattr:libattr +RSYNC_acl:libacl +RSYNC_zstd:libzstd +RSYNC_xxhash:libxxhash +RSYNC_lz4:liblz4 $(ICONV_DEPENDS)
URL:=https://rsync.samba.org/
MENU:=1
endef
@@ -47,18 +47,18 @@ CONFIGURE_ARGS += \
--without-included-zlib \
--disable-debug \
--disable-asm \
- --disable-lz4 \
--disable-locale \
--disable-md2man \
--disable-openssl \
--disable-simd \
--disable-roll-simd \
- --disable-xxhash \
--$(if $(CONFIG_BUILD_NLS),en,dis)able-iconv \
--$(if $(CONFIG_BUILD_NLS),en,dis)able-iconv-open \
--$(if $(CONFIG_RSYNC_zstd),en,dis)able-zstd \
+ --$(if $(CONFIG_RSYNC_lz4),en,dis)able-lz4 \
--$(if $(CONFIG_RSYNC_xattr),en,dis)able-xattr-support \
--$(if $(CONFIG_RSYNC_acl),en,dis)able-acl-support \
+ --$(if $(CONFIG_RSYNC_xxhash),en,dis)able-xxhash \
$(if $(CONFIG_IPV6),,--disable-ipv6)
define Package/rsyncd