aboutsummaryrefslogtreecommitdiff
path: root/net/rpcbind
diff options
context:
space:
mode:
authorAndy Walsh <andy.walsh44+github@gmail.com>2018-08-19 16:33:42 +0200
committerAndy Walsh <andy.walsh44+github@gmail.com>2018-08-19 16:36:03 +0200
commit7a88e515d099fb74a3c8426d1e2b875b1903a12d (patch)
treef151879ae4e9e8032d66977d780b821314751415 /net/rpcbind
parent23efd1f3f14e5724ba32dc3ee5e4d99accd8c80a (diff)
rpcbind: update to 1.2.5
* update to 1.2.5 * fix wrong URL * adapt to bin/sbin from new version Signed-off-by: Andy Walsh <andy.walsh44+github@gmail.com>
Diffstat (limited to 'net/rpcbind')
-rw-r--r--net/rpcbind/Makefile12
-rw-r--r--net/rpcbind/files/rpcbind.init2
2 files changed, 8 insertions, 6 deletions
diff --git a/net/rpcbind/Makefile b/net/rpcbind/Makefile
index bf0ea7b54..434f7a974 100644
--- a/net/rpcbind/Makefile
+++ b/net/rpcbind/Makefile
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rpcbind
-PKG_VERSION:=0.2.4
-PKG_RELEASE:=2
+PKG_VERSION:=1.2.5
+PKG_RELEASE:=1
PKG_SOURCE_URL:=@SF/rpcbind
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_HASH:=074a9a530dc7c11e0d905aa59bcb0847c009313f02e98d3d798aa9568f414c66
+PKG_HASH:=2ce360683963b35c19c43f0ee2c7f18aa5b81ef41c3fdbd15ffcb00b8bffda7a
PKG_MAINTAINER:=Andy Walsh <andy.walsh44+github@gmail.com>
PKG_LICENSE:=BSD-3-Clause
@@ -26,7 +26,7 @@ define Package/rpcbind
CATEGORY:=Network
DEPENDS:=+libtirpc +RPCBIND_LIBWRAP:libwrap
TITLE:=Universal addresses to RPC mapper
- URL:=http://libtirpc.sourceforge.net/
+ URL:=http://rpcbind.sourceforge.net/
USERID:=rpc=65533:rpc=65533
endef
@@ -67,7 +67,9 @@ endif
define Package/rpcbind/install
$(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/{rpcbind,rpcinfo} $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/rpcinfo $(1)/usr/bin/
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/rpcbind $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/rpcbind.init $(1)/etc/init.d/rpcbind
endef
diff --git a/net/rpcbind/files/rpcbind.init b/net/rpcbind/files/rpcbind.init
index f3efaed3c..2e8ace041 100644
--- a/net/rpcbind/files/rpcbind.init
+++ b/net/rpcbind/files/rpcbind.init
@@ -7,7 +7,7 @@ USE_PROCD=1
start_service() {
procd_open_instance
- procd_set_param command /usr/bin/rpcbind -f -w
+ procd_set_param command /usr/sbin/rpcbind -f -w
procd_set_param respawn
procd_close_instance
}