aboutsummaryrefslogtreecommitdiff
path: root/net/restic-rest-server/Makefile
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2021-02-24 15:37:12 -0300
committerEneas U de Queiroz <cotequeiroz@gmail.com>2021-02-24 16:12:55 -0300
commitb732157dec0be4d90aad5cec48056bd69939bb45 (patch)
treeaba712d8dbc9a2a7fb7f020515d3b09cb3827072 /net/restic-rest-server/Makefile
parenta2b08b5cbfb655d853a92f845d7e93e6b4031456 (diff)
restic-rest-server: fix build with golang 1.16
Add GO111MODULE=auto to GO_PKG_BUILD_VARS to allow the package to be built in non-module mode. Module-aware mode will be mandatory in the next golang release. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'net/restic-rest-server/Makefile')
-rw-r--r--net/restic-rest-server/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/net/restic-rest-server/Makefile b/net/restic-rest-server/Makefile
index 87288f20f..68632bdce 100644
--- a/net/restic-rest-server/Makefile
+++ b/net/restic-rest-server/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=restic-rest-server
PKG_VERSION:=0.9.7
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_BUILD_DIR:=$(BUILD_DIR)/rest-server-$(PKG_VERSION)
PKG_SOURCE:=rest-server-$(PKG_VERSION).tar.gz
@@ -43,6 +43,8 @@ API. It provides secure and efficient way to backup data remotely, using restic
backup client via the rest: URL.
endef
+GO_PKG_BUILD_VARS += GO111MODULE=auto
+
define Package/restic-rest-server/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(GO_PKG_BUILD_BIN_DIR)/rest-server $(1)/usr/bin/restic-rest-server