aboutsummaryrefslogtreecommitdiff
path: root/net/respondd/Makefile
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2023-03-30 04:56:25 +0200
committerDavid Bauer <mail@david-bauer.net>2023-03-31 12:44:26 +0200
commitbbfd3f9709c25d774a2a64f3fd410b5e8339c9d5 (patch)
tree8615e0df8254265766163374a1dd09f3f21d2537 /net/respondd/Makefile
parent6e0c2b767b37de4f4c9fee1e5219829ee467b8ac (diff)
respondd: add package
This adds the respondd package, a protocol used primarily with Freifunk and the Gluon mesh-framework for collecting statistics. For more information, see the project readme. Ref: https://github.com/freifunk-gluon/respondd/ Tested: mpc85xx-p1020 / mediatek-filogic Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'net/respondd/Makefile')
-rw-r--r--net/respondd/Makefile64
1 files changed, 64 insertions, 0 deletions
diff --git a/net/respondd/Makefile b/net/respondd/Makefile
new file mode 100644
index 000000000..d46984acd
--- /dev/null
+++ b/net/respondd/Makefile
@@ -0,0 +1,64 @@
+#
+# Copyright (C) 2023 David Bauer <mail@david-bauer.net>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=respondd
+PKG_SOURCE_DATE:=2019-05-01
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/freifunk-gluon/respondd.git
+PKG_SOURCE_VERSION:=58405297e76f97d4752dc7511dc15bbc7a01e586
+PKG_MIRROR_HASH:=22bc00df280fe611cfc895528f17269f03af804ea4c2ca2dc62da2457d3a1ee0
+
+PKG_MAINTAINER:=David Bauer <mail@david-bauer.net>
+PKG_LICENSE:=BSD-2-Clause
+
+CMAKE_SOURCE_SUBDIR:=src
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/respondd
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=@IPV6 +libjson-c
+ TITLE:=Lightweight metadata multicast-responder
+endef
+
+define Package/respondd/description
+respondd is a server distributing information within a network.
+
+For doing so, respondd spawns a UDP socket (in Gluon 1001/udp),
+optionally joining a multicast group. When a request is received,
+the information requested is transmitted to the requester.
+
+All information is organized in a non-hierarchical namespace.
+Each entry identifies a request name (e.g. statistics, nodeinfo, ...)
+implemented by at least one "provider" C module. The respond is the
+result of merging the outputs of all providers for the given request
+name.
+endef
+
+define Package/respondd/conffiles
+/etc/config/respondd
+endef
+
+define Package/respondd/install
+ $(INSTALL_DIR) $(1)/usr/bin $(1)/etc/init.d $(1)/etc/config
+ $(INSTALL_CONF) ./files/respondd.config $(1)/etc/config/respondd
+ $(INSTALL_BIN) ./files/respondd.init $(1)/etc/init.d/respondd
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/respondd $(1)/usr/bin/
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/src/respondd.h $(1)/usr/include/
+endef
+
+$(eval $(call BuildPackage,respondd))