aboutsummaryrefslogtreecommitdiff
path: root/net/redsocks/patches
diff options
context:
space:
mode:
authorSergey V. Lobanov <sergey@lobanov.in>2022-01-11 23:11:48 +0300
committerRosen Penev <rosenp@gmail.com>2022-01-17 21:09:19 -0800
commit5cd8b75f943853a763c1336d09254d9470c76f94 (patch)
tree08e7cce01fa4c32116baa5513761444ca01ce4ea /net/redsocks/patches
parentec252c20cc635fb65f972facfcdc8756099a21dd (diff)
redsocks: fix build on macos
fix cross-compile issues (on macos) use $CC -dumpmachine instead of `uname` use $CC instead of CC Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
Diffstat (limited to 'net/redsocks/patches')
-rw-r--r--net/redsocks/patches/100_use_cc_dumpmachine_instead_of_uname.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/net/redsocks/patches/100_use_cc_dumpmachine_instead_of_uname.patch b/net/redsocks/patches/100_use_cc_dumpmachine_instead_of_uname.patch
new file mode 100644
index 000000000..a56ca128e
--- /dev/null
+++ b/net/redsocks/patches/100_use_cc_dumpmachine_instead_of_uname.patch
@@ -0,0 +1,34 @@
+From https://github.com/darkk/redsocks/pull/105
+
+commit d5cabecb6a8369fb2bd883b43205035dd87187a5
+Author: a7ypically <a7ypically@gmail.com>
+Date: Sat Jun 3 21:33:20 2017 +0300
+
+ Update Makefile
+
+--- a/Makefile
++++ b/Makefile
+@@ -26,11 +26,11 @@ tags: *.c *.h
+ ctags -R
+
+ $(CONF):
+- @case `uname` in \
+- Linux*) \
++ @case `$(CC) -dumpmachine` in \
++ *linux*) \
+ echo "#define USE_IPTABLES" >$(CONF) \
+ ;; \
+- OpenBSD) \
++ *openbsd*) \
+ echo "#define USE_PF" >$(CONF) \
+ ;; \
+ *) \
+@@ -66,7 +66,7 @@ gen/.build:
+ base.c: $(CONF)
+
+ $(DEPS): $(SRCS)
+- gcc -MM $(SRCS) 2>/dev/null >$(DEPS) || \
++ $(CC) -MM $(SRCS) 2>/dev/null >$(DEPS) || \
+ ( \
+ for I in $(wildcard *.h); do \
+ export $${I//[-.]/_}_DEPS="`sed '/^\#[ \t]*include \?"\(.*\)".*/!d;s//\1/' $$I`"; \