aboutsummaryrefslogtreecommitdiff
path: root/net/ptunnel-ng/Makefile
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2018-11-26 19:26:32 +0100
committerToni Uhlig <matzeton@googlemail.com>2018-12-04 14:45:12 +0100
commit961f3acf16290b86ab6c776e6c85521fdf9e4f28 (patch)
tree85ff8dcf02f400f8c9ec5c9cb1455833fd7addab /net/ptunnel-ng/Makefile
parenta21282bd0461089c343b4b91513f445139dbf200 (diff)
ptunnel-ng: add new package
Ptunnel-NG is a bugfixed and refactored version of Ptunnel. Ptunnel is an application that allows you to reliably tunnel TCP connections to a remote host using ICMP echo request and reply packets, commonly known as ping requests and replies. Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
Diffstat (limited to 'net/ptunnel-ng/Makefile')
-rw-r--r--net/ptunnel-ng/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/net/ptunnel-ng/Makefile b/net/ptunnel-ng/Makefile
new file mode 100644
index 000000000..be9a7346a
--- /dev/null
+++ b/net/ptunnel-ng/Makefile
@@ -0,0 +1,40 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ptunnel-ng
+PKG_VERSION:=1.31
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/lnslbrty/ptunnel-ng/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=8324741f55aae8ccee6800912662a429774378088d81028a5f3f62f3ea9edaf4
+
+PKG_LICENSE:=BSD-3
+PKG_LICENSE_FILES:=COPYING
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ptunnel-ng
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=+libpthread
+ TITLE:=PingTunnel [N]ew[G]eneration
+ MAINTAINER:=Toni Uhlig <matzeton@googlemail.com>
+ URL:=https://github.com/lnslbrty/ptunnel-ng
+endef
+
+define Package/ptunnel-ng/description
+ Tunnel TCP connections through ICMP.
+endef
+
+CONFIGURE_ARGS += \
+ --disable-pcap \
+ --disable-selinux
+
+define Package/ptunnel-ng/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/sbin/$(PKG_NAME)
+endef
+
+$(eval $(call BuildPackage,ptunnel-ng))