aboutsummaryrefslogtreecommitdiff
path: root/net/prosody/Makefile
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2019-06-20 13:25:59 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2019-06-21 09:52:32 +0800
commit9ac5ac81ab2241b7c13c01e8801e0e7d95ebb4eb (patch)
tree8e917b35332bcae8517d6291258d80f0d44d4b46 /net/prosody/Makefile
parent274b111782c1d7650ae244a16e141e39d339af32 (diff)
treewide: avoid deref symlinks when installing .so
This change is inspired by commit openwrt/openwrt@38b22b1e ("nghttp2: deduplicate files in libnghttp2") The packages in this commit are identified with the following command grep -rin -E 'INSTALL_(DATA|BIN)' | grep -F '.so' | grep -F '*' Some of them do not have symlinks and are not affected, but the change is still applied for consideration of best practices just in case Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'net/prosody/Makefile')
-rw-r--r--net/prosody/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net/prosody/Makefile b/net/prosody/Makefile
index c5c0d8913..1720af76d 100644
--- a/net/prosody/Makefile
+++ b/net/prosody/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=prosody
PKG_VERSION:=0.11.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://prosody.im/downloads/source
@@ -104,10 +104,10 @@ define Package/prosody/install
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/net/websocket/*.lua $(1)/usr/lib/prosody/net/websocket/
$(INSTALL_DIR) $(1)/usr/lib/prosody/util
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/util/*.lua $(1)/usr/lib/prosody/util/
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/prosody/util/*.so $(1)/usr/lib/prosody/util/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/prosody/util/*.so $(1)/usr/lib/prosody/util/
$(INSTALL_DIR) $(1)/usr/lib/prosody/util/sasl
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/util/sasl/*.lua $(1)/usr/lib/prosody/util/sasl/
- #$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/prosody/util/sasl/*.so $(1)/usr/lib/prosody/util/sasl/
+ #$(CP) $(PKG_INSTALL_DIR)/usr/lib/prosody/util/sasl/*.so $(1)/usr/lib/prosody/util/sasl/
endef
define Package/prosody/postinst