aboutsummaryrefslogtreecommitdiff
path: root/net/privoxy/Makefile
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2017-03-07 13:41:01 +0100
committerStijn Tintel <stijn@linux-ipv6.be>2017-03-08 21:15:20 +0100
commitf82287cf5c1b2acd46feb52fb9b3cb3697e7086b (patch)
treeb51dc0c6f1eeb94b0cbd039b352d79c8a82d2736 /net/privoxy/Makefile
parent694e5a677cdacf0966d759deb75f03c0c927bd2a (diff)
treewide: use name in define and eval lines
For consistency, use full name instead of $(PKG_NAME) in define and eval lines for all packages. I've seen reviews that asked to do this before, and I am asking the same during reviews now. To avoid this in the future, fix this treewide so when people use existing packages as example, we will not have to request this change anymore. This makes all packages consistent with both LEDE and OpenWrt base repositories. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'net/privoxy/Makefile')
-rw-r--r--net/privoxy/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/net/privoxy/Makefile b/net/privoxy/Makefile
index 8d482089b..74fae2261 100644
--- a/net/privoxy/Makefile
+++ b/net/privoxy/Makefile
@@ -49,7 +49,7 @@ PKG_CONFIG_DEPENDS:= \
include $(INCLUDE_DIR)/package.mk
-define Package/$(PKG_NAME)
+define Package/privoxy
SECTION:=net
CATEGORY:=Network
SUBMENU:=Web Servers/Proxies
@@ -61,12 +61,12 @@ define Package/$(PKG_NAME)
endef
# shown in LuCI package description
-define Package/$(PKG_NAME)/description
+define Package/privoxy/description
$(TITLE) - Homepage: www.privoxy.org
endef
# shown in make menuconfig <Help>
-define Package/$(PKG_NAME)/config
+define Package/privoxy/config
help
Privoxy is a web proxy with advanced filtering capabilities for protecting
privacy, modifying web page content, managing cookies, controlling access,
@@ -110,14 +110,14 @@ CONFIGURE_ARGS += \
# needed otherwise errors during compile
MAKE_FLAGS:=
-define Package/$(PKG_NAME)/conffiles
+define Package/privoxy/conffiles
/etc/config/privoxy
/etc/privoxy/user.action
/etc/privoxy/user.filter
/etc/privoxy/user.trust
endef
-define Package/$(PKG_NAME)/preinst
+define Package/privoxy/preinst
#!/bin/sh
[ -n "$${IPKG_INSTROOT}" ] && exit 0 # if run within buildroot exit
@@ -127,7 +127,7 @@ define Package/$(PKG_NAME)/preinst
exit 0 # suppress errors from stop command
endef
-define Package/$(PKG_NAME)/install
+define Package/privoxy/install
if [ -f $(PKG_INSTALL_DIR)/etc/privoxy/trust ]; then \
mv -f $(PKG_INSTALL_DIR)/etc/privoxy/trust $(PKG_INSTALL_DIR)/etc/privoxy/user.trust; \
fi
@@ -155,10 +155,10 @@ define Package/$(PKG_NAME)/install
$(INSTALL_CONF) ./files/privoxy.config $(1)/etc/config/privoxy
endef
-define Package/$(PKG_NAME)/postinst
+define Package/privoxy/postinst
#!/bin/sh
grep -i privoxy $${IPKG_INSTROOT}/etc/services >/dev/null 2>&1 || \
echo -e "privoxy\t8118" >> $${IPKG_INSTROOT}/etc/services
endef
-$(eval $(call BuildPackage,$(PKG_NAME)))
+$(eval $(call BuildPackage,privoxy))