aboutsummaryrefslogtreecommitdiff
path: root/net/privoxy/Makefile
diff options
context:
space:
mode:
authorChristian Schoenebeck <christian.schoenebeck@gmail.com>2016-02-07 21:52:02 +0100
committerChristian Schoenebeck <christian.schoenebeck@gmail.com>2016-02-07 21:52:02 +0100
commitba929dd1f75a7a2e1123bdb4de558c78a008734f (patch)
tree6da18e13bcf3efbc956b5cc9078dd18fb05d6f16 /net/privoxy/Makefile
parent6d0f8aaef5417cae4d3e6f2dc72769f0fa8bfb83 (diff)
privoxy: bump to version 3.0.24
* upstream to Privoxy 3.0.24 * add facility to set compile options * add file list to be saved on sysupgrade * fixed PKG_MAINTAINER string * add port 8118 used by privoxy to /etc/services * new "boot_delay" option (default 10 seconds) to wait for interfaces to come up before hotplug restarts are enabled Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com>
Diffstat (limited to 'net/privoxy/Makefile')
-rw-r--r--net/privoxy/Makefile95
1 files changed, 75 insertions, 20 deletions
diff --git a/net/privoxy/Makefile b/net/privoxy/Makefile
index 8c5ca2c87..a51b36f94 100644
--- a/net/privoxy/Makefile
+++ b/net/privoxy/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=privoxy
-PKG_VERSION:=3.0.23
-PKG_RELEASE:=4
+PKG_VERSION:=3.0.24
+PKG_RELEASE:=1
PKG_SOURCE:=privoxy-$(PKG_VERSION)-stable-src.tar.gz
PKG_SOURCE_URL:=@SF/ijbswa
-PKG_MD5SUM:=bbe47d5ff1a54d9f9fc93a160532697f
+PKG_MD5SUM:=44a47d1a5000db8cccd61ace0e25e7f7
PKG_BUILD_DIR:=$(BUILD_DIR)/privoxy-$(PKG_VERSION)-stable
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
@@ -21,7 +21,31 @@ PKG_INSTALL:=1
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=LICENSE
-PKG_MAINTAINER:=christian.schoenebeck@gmail.com
+PKG_MAINTAINER:=Christian Schoenebeck <christian.schoenebeck@gmail.com>
+
+PKG_CONFIG_DEPENDS:= \
+ CONFIG_IPV6 \
+ \
+ CONFIG_PRIVOXY_disable-pthread \
+ CONFIG_PRIVOXY_disable-dynamic-pcre \
+ CONFIG_PRIVOXY_disable-zlib \
+ \
+ CONFIG_PRIVOXY_disable-toggle \
+ CONFIG_PRIVOXY_disable-force \
+ CONFIG_PRIVOXY_disable-fast-redirects \
+ CONFIG_PRIVOXY_disable-stats \
+ CONFIG_PRIVOXY_enable-ie-images \
+ CONFIG_PRIVOXY_disable-image-blocking \
+ CONFIG_PRIVOXY_disable-acl-support \
+ CONFIG_PRIVOXY_disable-trust-files \
+ CONFIG_PRIVOXY_disable-editor \
+ CONFIG_PRIVOXY_enable-no-gifs \
+ CONFIG_PRIVOXY_enable-graceful-termination \
+ CONFIG_PRIVOXY_enable-extended-host-patterns \
+ CONFIG_PRIVOXY_enable-external-filters \
+ CONFIG_PRIVOXY_enable-accept-filter \
+ CONFIG_PRIVOXY_enable-strptime-sanity-checks \
+ CONFIG_PRIVOXY_enable-compression
include $(INCLUDE_DIR)/package.mk
@@ -29,10 +53,11 @@ define Package/$(PKG_NAME)
SECTION:=net
CATEGORY:=Network
SUBMENU:=Web Servers/Proxies
- DEPENDS:=+libpcre +libpthread +zlib
TITLE:=Privoxy WEB Proxy
URL:=http://www.privoxy.org/
USERID:=privoxy=8118:privoxy=8118
+ MENU:=1
+ DEPENDS:=+!PRIVOXY_no_pcre:libpcre +!PRIVOXY_no_pthread:libpthread +!PRIVOXY_no_zlib:zlib
endef
# shown in LuCI package description
@@ -42,23 +67,45 @@ endef
# shown in make menuconfig <Help>
define Package/$(PKG_NAME)/config
-help
- Privoxy is a web proxy with advanced filtering capabilities for protecting
- privacy, modifying web page content, managing cookies, controlling access,
- and removing ads, banners, pop-ups and other obnoxious Internet junk.
- Privoxy has a very flexible configuration and can be customized to suit
- individual needs and tastes.
- Privoxy has application for both stand-alone systems and multi-user networks.
-
- Run as : $(USERID)
- Version: $(PKG_VERSION)-$(PKG_RELEASE)
- Home : $(URL)
-
- $(PKG_MAINTAINER)
+ help
+ Privoxy is a web proxy with advanced filtering capabilities for protecting
+ privacy, modifying web page content, managing cookies, controlling access,
+ and removing ads, banners, pop-ups and other obnoxious Internet junk.
+ Privoxy has a very flexible configuration and can be customized to suit
+ individual needs and tastes.
+ Privoxy has application for both stand-alone systems and multi-user networks.
+ Run as : $(USERID)
+ Version: $(PKG_VERSION)-$(PKG_RELEASE)
+ Home : $(URL)
+ $(PKG_MAINTAINER)
+
+ source "$(SOURCE)/Config.in"
endef
CONFIGURE_ARGS += \
- --sysconfdir=/etc/privoxy
+ --sysconfdir=/etc/privoxy \
+ $(if $(CONFIG_IPV6),,--disable-ipv6-support) \
+ \
+ $(if $(CONFIG_PRIVOXY_disable-pthread),--disable-pthread) \
+ $(if $(CONFIG_PRIVOXY_disable-dynamic-pcre),--disable-dynamic-pcre) \
+ $(if $(CONFIG_PRIVOXY_disable-zlib),--disable-zlib) \
+ \
+ $(if $(CONFIG_PRIVOXY_disable-toggle),--disable-toggle) \
+ $(if $(CONFIG_PRIVOXY_disable-force),--disable-force) \
+ $(if $(CONFIG_PRIVOXY_disable-fast-redirects),--disable-fast-redirects) \
+ $(if $(CONFIG_PRIVOXY_disable-stats),--disable-stats) \
+ $(if $(CONFIG_PRIVOXY_enable-ie-images),--enable-ie-images) \
+ $(if $(CONFIG_PRIVOXY_disable-image-blocking),--disable-image-blocking) \
+ $(if $(CONFIG_PRIVOXY_disable-acl-support),--disable-acl-support) \
+ $(if $(CONFIG_PRIVOXY_disable-trust-files),--disable-trust-files) \
+ $(if $(CONFIG_PRIVOXY_disable-editor),--disable-editor) \
+ $(if $(CONFIG_PRIVOXY_enable-no-gifs),--enable-no-gifs) \
+ $(if $(CONFIG_PRIVOXY_enable-graceful-termination),--enable-graceful-termination) \
+ $(if $(CONFIG_PRIVOXY_enable-extended-host-patterns),--enable-extended-host-patterns) \
+ $(if $(CONFIG_PRIVOXY_enable-external-filters),--enable-external-filters) \
+ $(if $(CONFIG_PRIVOXY_enable-accept-filter),--enable-accept-filter) \
+ $(if $(CONFIG_PRIVOXY_enable-strptime-sanity-checks),--enable-strptime-sanity-checks) \
+ $(if $(CONFIG_PRIVOXY_enable-compression),--enable-compression)
# needed otherwise errors during compile
MAKE_FLAGS:=
@@ -98,12 +145,20 @@ define Package/$(PKG_NAME)/install
-exec install -m0664 -t $(1)/etc/privoxy {} \;
$(INSTALL_DIR) \
+ $(1)/lib/upgrade/keep.d \
$(1)/etc/init.d \
$(1)/etc/hotplug.d/iface \
$(1)/etc/config
+ $(INSTALL_DATA) ./files/privoxy.upgrade $(1)/lib/upgrade/keep.d/privoxy
$(INSTALL_BIN) ./files/privoxy.init $(1)/etc/init.d/privoxy
$(INSTALL_BIN) ./files/privoxy.hotplug $(1)/etc/hotplug.d/iface/80-privoxy
$(INSTALL_CONF) ./files/privoxy.config $(1)/etc/config/privoxy
endef
+define Package/$(PKG_NAME)/postinst
+ #!/bin/sh
+ grep -i privoxy $${IPKG_INSTROOT}/etc/services >/dev/null 2>&1 || \
+ echo -e "privoxy\t8118" >> $${IPKG_INSTROOT}/etc/services
+endef
+
$(eval $(call BuildPackage,$(PKG_NAME)))