aboutsummaryrefslogtreecommitdiff
path: root/net/privoxy/Makefile
diff options
context:
space:
mode:
authorChristian Schoenebeck <christian.schoenebeck@gmail.com>2014-12-23 10:50:51 +0100
committerChristian Schoenebeck <christian.schoenebeck@gmail.com>2014-12-23 10:50:51 +0100
commit6aa05568b818594f73d9a148d37d8c5859c3c735 (patch)
tree75df1f02fa08e62777f08c28788280402895f76c /net/privoxy/Makefile
parent45cb1f563f655af642cbcc9ca9f5eaec4c9ef295 (diff)
[privoxy] remove using procd
* go back to "old" initscript not using procd * privoxy running --no-daemon only logging to STDERR * procd do not support redirection of STDOUT/STDERR, '2>file' as a command parameter does not work Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com>
Diffstat (limited to 'net/privoxy/Makefile')
-rw-r--r--net/privoxy/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/net/privoxy/Makefile b/net/privoxy/Makefile
index 80083d27c..4209cae4c 100644
--- a/net/privoxy/Makefile
+++ b/net/privoxy/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=privoxy
PKG_VERSION:=3.0.22
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable-src.tar.gz
PKG_SOURCE_URL:=@SF/ijbswa
@@ -47,7 +47,7 @@ Version: $(PKG_VERSION)-$(PKG_RELEASE)
endef
CONFIGURE_ARGS += \
- --sysconfdir=/etc/privoxy \
+ --sysconfdir=/etc/privoxy
# needed otherwise errors during compile
MAKE_FLAGS:=
@@ -67,9 +67,8 @@ define Package/privoxy/preinst
#!/bin/sh
# if run within buildroot exit
[ -n "$${IPKG_INSTROOT}" ] && exit 0
- # stop service # if PKG_UPGRADE NOT WORKING
- # [ "$${PKG_UPGRADE}" = "1" ] && /etc/init.d/privoxy stop
- /etc/init.d/privoxy stop >/dev/null 2>&1
+ # stop service if PKG_UPGRADE
+ [ "$${PKG_UPGRADE}" = "1" ] && /etc/init.d/privoxy stop >/dev/null 2>&1
exit 0 # supress errors from stop command
endef
@@ -78,9 +77,8 @@ define Package/privoxy/install
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/privoxy $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/privoxy.init $(1)/etc/init.d/privoxy
- # no longer needed because running with procd
- # $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
- # $(INSTALL_BIN) ./files/privoxy.hotplug $(1)/etc/hotplug.d/iface/80-privoxy
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+ $(INSTALL_BIN) ./files/privoxy.hotplug $(1)/etc/hotplug.d/iface/80-privoxy
$(INSTALL_DIR) $(1)/etc/privoxy
$(CP) $(PKG_INSTALL_DIR)/etc/privoxy/* $(1)/etc/privoxy/
@@ -89,7 +87,7 @@ define Package/privoxy/install
$(INSTALL_CONF) ./files/privoxy.oldconfig $(1)/etc/privoxy/config
# create .old file to be removed with next pacakge builds during update
$(INSTALL_CONF) ./files/privoxy.oldconfig $(1)/etc/privoxy/config.old
-
+ # copy NEW config
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_CONF) ./files/privoxy.config $(1)/etc/config/privoxy
endef