aboutsummaryrefslogtreecommitdiff
path: root/net/phantap
diff options
context:
space:
mode:
authorEtienne Champetier <champetier.etienne@gmail.com>2022-02-12 22:58:45 -0500
committerEtienne Champetier <champetier.etienne@gmail.com>2022-02-12 23:20:54 -0500
commit66b7c19992688b924d2ecbbbc20781b32a82452f (patch)
tree939b16ffd8c1d9ed4acea061929d15d4e89cbe0e /net/phantap
parentccf8450ed2864e0fe2b8ede2d1d7b3601fa9adac (diff)
phantap: switch to nftables
e80be64 Remove disable_eap_hack b066ce2 Switch to nftables / firewall4 4d88b0b Do not harcode build flags Signed-off-by: Etienne Champetier <champetier.etienne@gmail.com>
Diffstat (limited to 'net/phantap')
-rw-r--r--net/phantap/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/net/phantap/Makefile b/net/phantap/Makefile
index aa150ecfe..74eaa3c7a 100644
--- a/net/phantap/Makefile
+++ b/net/phantap/Makefile
@@ -11,9 +11,9 @@ PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/nccgroup/phantap
-PKG_MIRROR_HASH:=f57fac81fe7ee875456c2d7e841237f5f43058c681e26d7dd782463ff8e67779
-PKG_SOURCE_DATE:=2021.08.22
-PKG_SOURCE_VERSION:=26bd87685272906a59563a5c1e5eb3ea41bcfec3
+PKG_MIRROR_HASH:=b5a8658d9347bb7bc295a224f8f546582ca8a766e904b8004cd0a19d7b65d400
+PKG_SOURCE_DATE:=2022.02.12
+PKG_SOURCE_VERSION:=e80be64901c96f9340d33f79d719faf3d93cd7f0
PKG_MAINTAINER:=Diana Dragusin <diana.dragusin@nccgroup.com>, \
Etienne Champetier <champetier.etienne@gmail.com>
@@ -34,7 +34,7 @@ define Package/phantap
$(call Package/phantap/Default)
TITLE:=PhanTap
PKGARCH:=all
- DEPENDS:=+ebtables +libpcap +libnl-tiny +ip-full +kmod-br-netfilter +kmod-ebtables-ipv4
+ DEPENDS:=+libpcap +libnl-tiny +ip-full +kmod-nft-bridge
endef
define Package/phantap/conffiles
@@ -57,8 +57,6 @@ define Package/phantap/install
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) $(PKG_BUILD_DIR)/files/etc/init.d/phantap $(1)/etc/init.d/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/files/etc/init.d/phantap-early $(1)/etc/init.d/
- $(INSTALL_DIR) $(1)/etc/sysctl.d
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/files/etc/sysctl.d/12-phantap.conf $(1)/etc/sysctl.d/
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/phantap-learn $(1)/usr/sbin/
endef